Re: C-ISAM error -22 resolved
Posted in 1992
>Return-Path: <scott@igc.org> >Date: Wed, 8 Jan 92 23:04:02 PST >To: ellen@hpdmmgv.boi.hp.com >Subject: Re: C-ISAM error -22 resolved > >It doesn't matter if you "have 23 MB remaining on the disk after >the error". As soon as the error occurs, the temporary files will >be removed. You really need to check the disk space as you're >getting close to the error (or else start the job, then link all >the temp files in $DBTEMP to another directory so the inodes can't >be deleted, then make sure no new temp files are created or >dropped, then look in the save directory after the error). > >-scott No. I had 23 MB remaining on the disk AFTER the error and the tmp files where not removed. I was running isql on one UNIX workstation and accessing the database on another UNIX workstation via INET. The sqlexec process on the database server was STILL running and therefore the tmp tables did not get removed. Isql on the first workstation errored out and did not know of the existence of the tmp tables. -- - eko __ | | | | ___________________________________________________________ | \\ | | | \\ | Ellen K. Osinski | | | | Hewlett-Packard | \\ \\ | Boise Site Operations - Boise Surface Mount Center | / \\ | 11413 Chinden Blvd | | ---/\\ | Boise, ID 83714-1023 | | | | | | | | phone : (208) 323-4904 | | * | | e-mail: ellen@hpdmmgv.boi.hp.com | | | | telnet: 1-323-4904 | |___________| |___________________________________________________________|