RE: Shared Memory on NT
Posted in 1999
Wolfgang,
This is the problem caused by Server Agent and Online Dynamic Server
services memory conflict. One way or another try
First - SHMBASE 0x2000000 (READ release notes for more info)
Second - After Shutting down Informix OnLine, stop Server Agent service.
Then after your hard drive backup
1) start Online
2) start Server Agent
in order. Let me know if you have any other questions.
Gursoy YERLI
> -----Original Message-----
> From: Wolfgang Zager
> Sent: Tuesday, September 14, 1999 7:44 AM
> To: informix-list@iiug.org
> Subject: Shared Memory on NT
>
> Hello out there,
>
> we have the following strange behaviour on an Windows NT 4.0 SP 3 with
> IDS 7.22 TC1.
>
> Each night we are using a cmd-script to shutdown the db-server using
> onmode -ky.> After doing a complete backup of the hard-drive, another script tries to
> start
> the db-server again. Most of the time everything works fine. But
> sometimes we get
> errors like the following, when trying to bring IDS online.
>
> 11:39:22 shmget: [EEXIST][17]: key 52564801: Shared Memory bereits> vorhanden
> 11:39:27 mt_shm_init: Segment resident kann nicht angelegt werden>
> In each case the online log states, that online terminated correctly
> without any errors.
>
> Any ideas ?
>
> Wolfgang
>