Re: help: Shared memory init error
Posted in 1996
In article <596v43$cj6@hpcc48.corp.hp.com>, curt narvesen <curt-
narvesen@hp.com> writes
>I am running Informix 7.1e and tried to restore my database from a
>Unix backup tape. I tried to restore "users/informix" and
>"dev/yponline". Now when i try to bring my database online I get
>on the following error message "oninit: Fatal error in shared
>memory initialization". The message log file is as follows:
That just means that the engine did not startup.
>
>Could not disable priority aging: aging errno =2
>DR: DRAUTO is 0 (Off)
>warning: chunk timestamps are invalid
You're backup is corrupt. I assume you used an Informix tool
(ontape/onarchive) to back it up?
>
>I/O error, Primary chunk 'dev/yponline' -- Offline (sanity)
The chunk dev/yponline is not useable and so is taken offline.
>INFORMIX-OnLine Stopped
I assume this is part of the rootdbs or contains logs as online
then decides to shutdown.
>mt_shm_remove: WARNING: may not have removed all/correct segments
I did not go down cleanly.
>
>
>Could anyone offer me some advice?
First do another restore then check the permissions on
dev/ypline, it should be mode 660 (rw-rw----) owner informix,
group informix.
If that fails then I suggest Finding another backup as this one is
corrupted.
>
>
>Thanks
--
David Williams