Re: ISAM error: No more locks
Posted in 1998
Dirk Moolman wrote: > > Hi, I'm not to familiar with Online 5, but you can try the following 2 > commands > > tbstat -k (this will give you all the locks) > Within the above statement there is an "owner" column. You can take the > value in this column and do an > tbstat -u | grep <owner-id> > to get the owner of the lock > > This might show you who is using the most locks and you can then find out > what that person is doing. > > I hope this helps > Regards > Dirk > > Soporte Tecnico de Informix <infx.sup@gotec.com> wrote in article > <6jpoc6$i0b$1@news.xmission.com>... > > > > Hi folks: > > > > I have Informix Online 5.03, configured with 14000 locks in the > > shared memory. Althougth the applications in 4GL is now report the error > > ISAM: no more locks (134) or the sql: Could not do an indexed read to get > > the next row (246). The error is each day more and more frecuently, and > the > > problem is too poor, when i start the informix online and the error ocurr > > near inmediatily at startup!!! What happens? How i identify the > process > > what cause the problem? You need more locks! Try 100,000 they do not take up much space. Look for deletes and updates with broad WHERE clauses that are updating thousands of rows each. Art S. Kagel