Re: Update big tables !
Posted in 1998
Maciej Sawicki — — source: Informix-list mailing list archive (1991-1998)
Rok Vi=BEintin wrote: > I'm using Informix 7.30 and BUFFERED database. > > I want to update very big table and Long transaction error appears. > I usually do in this way: > 1. change database mode to NON LOGGING. > 2. update a table > 3. chnage database mode to BUFFERED again. > > Is teher any shortcut to do it. > Try the following: Lock table in exclusive mode, update and unlock table. Although it may not work in every situation, it solved my problems with updateing large tables. Maciek.