RE: Corruption in old and unsupported v7 database ...
Posted in 2004
Hi Neil.
Sorry. if I can not tell you what I want to do...
First figure out what table and page is currupt.
oncheck -pe, oncheck -pP or oncheck -pp.
Then figure out rowid of table on corrupt page.
unload to <TAPE DEVIDE, if possbile> select * from corrupt table where
rowid not in (.......)
unload other table to tape device.
Regards.
--
Tsutomu Ogiwara from Tokyo Japan.
ICQ#:168106592
>From: "Neil Truby" <neil.truby@ardenta.com>
>Reply-To: "Neil Truby" <neil.truby@ardenta.com>
>To: informix-list@iiug.org
>Subject: Corruption in old and unsupported v7 database ...
>Date: Mon, 16 Aug 2004 20:33:25 +0100
>
>My customer is on 7.2x on HP-UX 10.20.
>Informix support patched one of his chinks better a couple of months ago.
>Now (and probably then) he is getting page errors:
>
>Noticed assert failure af.5008e6dc which advised oncheck -cDI 8394250
>Dropped index tfgld1061001abaan
>Ran create unique index "baan".tfgld1061001abaanon "baan".ttfgld106100
>(hash1)
>Process halted with 25580:System erroroccurred in network function, invalid
>arguement
>Ran oncheck cDI 8394250 - It reported bad page, pg-stamp 155ccd15 !=
>PG_STAMP2 0
>Ran onckeck -cD 8394250 - It reported bad page 33a155f: pg_stamp 358403349
>!= PG_STAMP2 0
>
>He's keen to try and do an ASCII unload, but I think it will fail with the
>same thing. I'd like to get a copy of his database to work on, but we have
>no HP-UX 10.20 servers. He doesn't have enough disk space to
>onunlaod/onload the file to that server.
>
>Any other ideas for helping him out? IBM tech Support won;t touch it - the
>version is too old.
>
>thanks
>Neil
>
>
_________________________________________________________________
The new MSN 8: smart spam protection and 2 months FREE*
http://join.msn.com/?page=features/junkmail
sending to informix-list