Connection Manager fails w/network error -25572
Posted in 2012
Topics: High Availability & Replication, Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Security, Permissions & Auditing, Networking & sqlhosts Configuration, Platform-Specific Issues, Clustering, Grid & MACH11, Internationalization & Character Sets
Hello All,
I have an enterprise replication environment with a primary machine and a
backup machine. I am trying to use the connection manager in order implement
failover in a flexible grid, but I cannot establish communications from the
connection manager machine to the other machine. I have tried starting oncmsm
from both the primary machine and the backup machine (not at the same time),
but get the same error either way (i.e., the primary cannot access the backup,
or the backup cannot access the primary). The connection manager log shows the
following:
Cannot start listener <sla name>, network error -25572
I have verified the the port number is not in use, and I have tried using
different port numbers. I have also tried with and without using the
passwd_file.
Here are the details:
============================================================================
sqlhosts file: (same on both machines):
metro_server group - - i=50
metrotcp onsoctcp bugs 9005 g=metro_server
metroalias onipcshm bugs metro_bugs
metrobk_server group - - i=22
metrotcpbk onsoctcp elmer 9005 g=metrobk_server
metroaliasbk onipcshm elmer metro_elmer
sla_pri onsoctcp bugs 9006
sla_bak onsoctcp elmer 9006
connection manager config file: (same on both machines)
NAME cm1connection manager
LOG 1
LOGFILE ${INFORMIXDIR}/tmp/cm1.log
DEBUG 1
GRID STCLive
{
INFORMIXSERVER metrotcp
SLA sla_pri DBSERVERS=metrotcp
SLA sla_bak DBSERVERS=metrotcpbk
}
Primary .rhosts file:
elmer.spirent.com informix
Backup .rhosts file:
bugs.spirent.com informix
oncmsm output log: (if started on primary - bugs, using passwd_file)
09:28:40 IBM Informix Connection Manager
09:28:40 IBM Informix CSDK Version 3.70, IBM Informix-ESQL Version 3.70.UC4
09:28:40 Build Number: N125
09:28:40 Build Host: sun280-2
09:28:40 Build OS: SunOS-sparc 5.10
09:28:40 Build Date: Wed Oct 5 15:52:39 CDT 2011
09:28:40 GLS Version: glslib-5.00.UC5
09:28:40
09:28:40 DEBUG:SLA sla_pri type 0x423758 add 0x423778 [cmsm_sla.c::2131]
09:28:40 DEBUG:add server metrotcp to SLA sla_pri [cmsm_sla.c::2133]
09:28:40 SLA sla_pri listener mode REDIRECT
09:28:40 DEBUG:SLA sla_bak type 0x423798 add 0x4237b8 [cmsm_sla.c::2131]
09:28:40 DEBUG:add server metrotcpbk to SLA sla_bak [cmsm_sla.c::2133]
09:28:40 SLA sla_bak listener mode REDIRECT
09:28:40 Connection Manager name is cm1connection manager
09:28:40 Starting Connection Manager...
09:28:40 the current maximum number of file descriptors is 0
09:28:40 switch to daemon mode
09:28:40 DEBUG:new daemon pid is 26759 [cmsm_main.c::4129]
09:28:40 dbservername = metrotcp
09:28:40 nettype = onsoctcp
09:28:40 hostname = bugs
09:28:40 servicename = 9005
09:28:40 options = g=metro_server
09:28:40 DEBUG:connect to metrotcp for GRID STCLive [cmsm_server.ec::1836]
09:28:40 DEBUG:create new thread 2 for metrotcp [cmsm_sla.c::821]
09:28:40 DEBUG:connect to metrotcp ... [cmsm_er.ec::2484]
09:28:40 DEBUG:connect to metrotcpbk ... [cmsm_er.ec::2484]
09:28:40 DEBUG:create new thread 5 for metrotcpbk [cmsm_sla.c::821]
09:28:40 listener sla_pri initializing
09:28:40 listener sla_bak initializing
09:28:40 DEBUG:listenter sla_pri host=bugs service=9006 nettype=soctcp
engtypeon [cmsm_main.c::1086]
09:28:40 DEBUG:listenter sla_bak host=elmer service=9006 nettype=soctcp
engtypeon [cmsm_main.c::1086]
09:28:40 Listener sla_pri DBSERVERS=metrotcp is active with 4 worker threads
09:28:40 Warning: Cannot start listener sla_bak, network error -25572
09:28:40 DEBUG:database sysmaster @metrotcp|onsoctcp|bugs|9005 AS metrotcp0
SQLCODE = (0,0,) [cmsm_server.ec::149]
09:28:40 DEBUG:metrotcp protocols = 1 [cmsm_server.ec::1574]
09:28:40 DEBUG:adding metrotcp alias metroalias with protocol onipcshm 1
[cmsm_server.ec::1678]
09:28:41 DEBUG:SLA sla_bak listener failed [cmsm_main.c::4410]
09:28:41 DEBUG:SLA listener failed [cmsm_main.c::4446]
09:28:41 ALARM 1002 Error: SLA listener failed, Connection Manager can not
start
09:28:41 ALARM 1002 Failed to switch to daemon mode, Connection Manager stopped
oncmsm output log: (if started on primary - bugs, without using passwd_file)
09:31:56 IBM Informix Connection Manager
09:31:56 IBM Informix CSDK Version 3.70, IBM Informix-ESQL Version 3.70.UC4
09:31:56 Build Number: N125
09:31:56 Build Host: sun280-2
09:31:56 Build OS: SunOS-sparc 5.10
09:31:56 Build Date: Wed Oct 5 15:52:39 CDT 2011
09:31:56 GLS Version: glslib-5.00.UC5
09:31:56
09:31:56 DEBUG:SLA sla_pri type 0x423758 add 0x423778 [cmsm_sla.c::2131]
09:31:56 DEBUG:add server metrotcp to SLA sla_pri [cmsm_sla.c::2133]
09:31:56 SLA sla_pri listener mode REDIRECT
09:31:56 DEBUG:SLA sla_bak type 0x423798 add 0x4237b8 [cmsm_sla.c::2131]
09:31:56 DEBUG:add server metrotcpbk to SLA sla_bak [cmsm_sla.c::2133]
09:31:56 SLA sla_bak listener mode REDIRECT
09:31:56 Connection Manager name is cm1connection manager
09:31:56 Starting Connection Manager...
09:31:56 DEBUG:Password File /spirent/cots/informix/11.70/etc/passwd_file
failed, errno = 2 [cmsm_main.c::1683]
09:31:56 Warning: Password Manager failed; working in trusted node mode
09:31:56 the current maximum number of file descriptors is 0
09:31:56 switch to daemon mode
09:31:56 DEBUG:new daemon pid is 27895 [cmsm_main.c::4129]
09:31:56 dbservername = metrotcp
09:31:56 nettype = onsoctcp
09:31:56 hostname = bugs
09:31:56 servicename = 9005
09:31:56 options = g=metro_server
09:31:56 DEBUG:connect to metrotcp for GRID STCLive [cmsm_server.ec::1836]
09:31:56 DEBUG:create new thread 2 for metrotcp [cmsm_sla.c::821]
09:31:56 DEBUG:connect to metrotcp ... [cmsm_er.ec::2484]
09:31:56 listener sla_pri initializing
09:31:56 listener sla_bak initializing
09:31:56 DEBUG:listenter sla_pri host=bugs service=9006 nettype=soctcp
engtypeon [cmsm_main.c::1086]
09:31:56 DEBUG:listenter sla_bak host=elmer service=9006 nettype=soctcp
engtypeon [cmsm_main.c::1086]
09:31:56 09:31:56 DEBUG:Warning: Cannot start listener sla_bak, network error
-25572 connect to metrotcpbk ...
[cmsm_er.ec::2484]09:31:56 Listener sla_pri DBSERVERS=metrotcp is active with
4 worker threads
09:31:56 DEBUG:create new thread 9 for metrotcpbk [cmsm_sla.c::821]
09:31:56 DEBUG:SLA sla_bak listener failed [cmsm_main.c::4410]
09:31:56 DEBUG:SLA listener failed [cmsm_main.c::4446]
09:31:56 ALARM 1002 Error: SLA listener failed, Connection Manager can not
start
09:31:56 ALARM 1002 Failed to switch to daemon mode, Connection Manager stopped
oncmsm output log: (if started on backup - elmer, using passwd_file)
09:25:52 IBM Informix Connection Manager
09:25:52 IBM Informix CSDK Version 3.70, IBM Informix-ESQL Version 3.70.UC4
09:25:52 Build Number: N125
09:25:52 Build Host: aello
09:25:52 Build OS: AIX 1
09:25:52 Build Date: Wed Oct 5 15:26:24 CDT 2011
09:25:52 GLS Version: glslib-5.00.UC5
09:25:52
09:25:52 DEBUG:SLA sla_pri type 0x20225808 add 0x20225828
[cmsm_sla.c:parse_sla:2131]
09:25:52 DEBUG:add server metrotcp to SLA sla_pri [cmsm_sla.c:parse_sla:2133]
09:25:52 SLA sla_pri listener mode REDIRECT
09:25:52 DEBUG:SLA sla_bak type 0x202249d8 add 0x202249f8
[cmsm_sla.c:parse_sla:2131]@@NL@
The connection manage config file indicates that the CM will have two
listener threads, one for each of the SLAs. But your sqlhost file
indicates that those two listener threads are on differing machines. =
The
machine for the SLA listener thread must be on the same machine that t=
he
CM is running on.
From: "JEFFREY GENEGA" <jeffrey.genega@spirent.com>
To: ids@iiug.org,
Date: 06/07/2012 08:16 AM
Subject: Connection Manager fails w/network error -25572 [27308]
Sent by: ids-bounces@iiug.org
Hello All,
I have an enterprise replication environment with a primary machine and=
a
backup machine. I am trying to use the connection manager in order
implement
failover in a flexible grid, but I cannot establish communications from=
the
connection manager machine to the other machine. I have tried starting
oncmsm
from both the primary machine and the backup machine (not at the same
time),
but get the same error either way (i.e., the primary cannot access the
backup,
or the backup cannot access the primary). The connection manager log sh=
ows
the
following:
Cannot start listener <sla name>, network error -25572
I have verified the the port number is not in use, and I have tried usi=
ng
different port numbers. I have also tried with and without using the
passwd_file.
Here are the details:
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D
sqlhosts file: (same on both machines):
metro_server group - - i=3D50
metrotcp onsoctcp bugs 9005 g=3Dmetro_server
metroalias onipcshm bugs metro_bugs
metrobk_server group - - i=3D22
metrotcpbk onsoctcp elmer 9005 g=3Dmetrobk_server
metroaliasbk onipcshm elmer metro_elmer
sla_pri onsoctcp bugs 9006
sla_bak onsoctcp elmer 9006
connection manager config file: (same on both machines)
NAME cm1connection manager
LOG 1
LOGFILE ${INFORMIXDIR}/tmp/cm1.log
DEBUG 1
GRID STCLive
{
INFORMIXSERVER metrotcp
SLA sla_pri DBSERVERS=3Dmetrotcp
SLA sla_bak DBSERVERS=3Dmetrotcpbk
}
Primary .rhosts file:
elmer.spirent.com informix
Backup .rhosts file:
bugs.spirent.com informix
oncmsm output log: (if started on primary - bugs, using passwd_file)
09:28:40 IBM Informix Connection Manager
09:28:40 IBM Informix CSDK Version 3.70, IBM Informix-ESQL Version 3.70=
.UC4
09:28:40 Build Number: N125
09:28:40 Build Host: sun280-2
09:28:40 Build OS: SunOS-sparc 5.10
09:28:40 Build Date: Wed Oct 5 15:52:39 CDT 2011
09:28:40 GLS Version: glslib-5.00.UC5
09:28:40
09:28:40 DEBUG:SLA sla_pri type 0x423758 add 0x423778 [cmsm_sla.c::2131=
]
09:28:40 DEBUG:add server metrotcp to SLA sla_pri [cmsm_sla.c::2133]
09:28:40 SLA sla_pri listener mode REDIRECT
09:28:40 DEBUG:SLA sla_bak type 0x423798 add 0x4237b8 [cmsm_sla.c::2131=
]
09:28:40 DEBUG:add server metrotcpbk to SLA sla_bak [cmsm_sla.c::2133]
09:28:40 SLA sla_bak listener mode REDIRECT
09:28:40 Connection Manager name is cm1connection manager
09:28:40 Starting Connection Manager...
09:28:40 the current maximum number of file descriptors is 0
09:28:40 switch to daemon mode
09:28:40 DEBUG:new daemon pid is 26759 [cmsm_main.c::4129]
09:28:40 dbservername =3D metrotcp
09:28:40 nettype =3D onsoctcp
09:28:40 hostname =3D bugs
09:28:40 servicename =3D 9005
09:28:40 options =3D g=3Dmetro_server
09:28:40 DEBUG:connect to metrotcp for GRID STCLive [cmsm_server.ec::18=
36]
09:28:40 DEBUG:create new thread 2 for metrotcp [cmsm_sla.c::821]
09:28:40 DEBUG:connect to metrotcp ... [cmsm_er.ec::2484]
09:28:40 DEBUG:connect to metrotcpbk ... [cmsm_er.ec::2484]
09:28:40 DEBUG:create new thread 5 for metrotcpbk [cmsm_sla.c::821]
09:28:40 listener sla_pri initializing
09:28:40 listener sla_bak initializing
09:28:40 DEBUG:listenter sla_pri host=3Dbugs service=3D9006 nettype=3Ds=
octcp
engtypeon [cmsm_main.c::1086]
09:28:40 DEBUG:listenter sla_bak host=3Delmer service=3D9006 nettype=3D=
soctcp
engtypeon [cmsm_main.c::1086]
09:28:40 Listener sla_pri DBSERVERS=3Dmetrotcp is active with 4 worker
threads
09:28:40 Warning: Cannot start listener sla_bak, network error -25572
09:28:40 DEBUG:database sysmaster @metrotcp|onsoctcp|bugs|9005 AS metro=
tcp0
SQLCODE =3D (0,0,) [cmsm_server.ec::149]
09:28:40 DEBUG:metrotcp protocols =3D 1 [cmsm_server.ec::1574]
09:28:40 DEBUG:adding metrotcp alias metroalias with protocol onipcshm =
1
[cmsm_server.ec::1678]
09:28:41 DEBUG:SLA sla_bak listener failed [cmsm_main.c::4410]
09:28:41 DEBUG:SLA listener failed [cmsm_main.c::4446]
09:28:41 ALARM 1002 Error: SLA listener failed, Connection Manager can =
not
start
09:28:41 ALARM 1002 Failed to switch to daemon mode, Connection Manager=
stopped
oncmsm output log: (if started on primary - bugs, without using
passwd_file)
09:31:56 IBM Informix Connection Manager
09:31:56 IBM Informix CSDK Version 3.70, IBM Informix-ESQL Version 3.70=
.UC4
09:31:56 Build Number: N125
09:31:56 Build Host: sun280-2
09:31:56 Build OS: SunOS-sparc 5.10
09:31:56 Build Date: Wed Oct 5 15:52:39 CDT 2011
09:31:56 GLS Version: glslib-5.00.UC5
09:31:56
09:31:56 DEBUG:SLA sla_pri type 0x423758 add 0x423778 [cmsm_sla.c::2131=
]
09:31:56 DEBUG:add server metrotcp to SLA sla_pri [cmsm_sla.c::2133]
09:31:56 SLA sla_pri listener mode REDIRECT
09:31:56 DEBUG:SLA sla_bak type 0x423798 add 0x4237b8 [cmsm_sla.c::2131=
]
09:31:56 DEBUG:add server metrotcpbk to SLA sla_bak [cmsm_sla.c::2133]
09:31:56 SLA sla_bak listener mode REDIRECT
09:31:56 Connection Manager name is cm1connection manager
09:31:56 Starting Connection Manager...
09:31:56 DEBUG:Password File /spirent/cots/informix/11.70/etc/passwd_fi=
le
failed, errno =3D 2 [cmsm_main.c::1683]
09:31:56 Warning: Password Manager failed; working in trusted node mode=
09:31:56 the current maximum number of file descriptors is 0
09:31:56 switch to daemon mode
09:31:56 DEBUG:new daemon pid is 27895 [cmsm_main.c::4129]
09:31:56 dbservername =3D metrotcp
09:31:56 nettype =3D onsoctcp
09:31:56 hostname =3D bugs
09:31:56 servicename =3D 9005
09:31:56 options =3D g=3Dmetro_server
09:31:56 DEBUG:connect to metrotcp for GRID STCLive [cmsm_server.ec::18=
36]
09:31:56 DEBUG:create new thread 2 for metrotcp [cmsm_sla.c::821]
09:31:56 DEBUG:connect to metrotcp ... [cmsm_er.ec::2484]
09:31:56 listener sla_pri initializing
09:31:56 listener sla_bak initializing
09:31:56 DEBUG:listenter sla_pri host=3Dbugs service=3D9006 nettype=3Ds=
octcp
engtypeon [cmsm_main.c::1086]
09:31:56 DEBUG:listenter sla_bak host=3Delmer service=3D9006 nettype=3D=
soctcp
engtypeon [cmsm_main.c::1086]
09:31:56 09:31:56 DEBUG:Warning: Cannot start listener sla_bak, network=
error
-25572 connect to metrotcpbk ...
[cmsm_er.ec::2484]09:31:56 Listener sla_pri DBSERVERS=3Dmetrotcp is act=
ive
with
4 worker threads
09:31:56 DEBUG:create new thread 9 for metrotcpbk [cmsm_sla
Thanks a bunch Madison. That makes perfect sense, it's working now. -Jeff
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts