BladeManager on AIX4.2.1
Posted in 1998
I encountered the following problem with blademgr after the installation of INFORMIX US on AIX4.2.1. LIBPATH was (hopefully) set up right... informix@mysite ~$ echo $LIBPATH /usr/lib:/usr/local/informix/lib/cli:/usr/local/informix/lib/c++:/usr/local/informix/lib/esql:/usr/local/informix/lib/dmi:/usr/local/informix/lib but blademgr refused to start... informix@titan ~$ blademgr rtld: 0712-001 Symbol mi_last_serial8 was referenced from module /usr/lib/libc.a(pse.o), but a runtime definition of the symbol was not found. rtld: 0712-002 fatal error: exiting. However, I was able to statically link a new executable (myblademgr) which worked: informix@mysite ~$ !cc cc -o myblademgr blademgr /usr/local/informix/lib/*.a /usr/local/informix/lib/dmi/*.a /usr/local/informix/lib/esql/*.a /usr/local/informix/lib/c++/*.a /usr/local/informix/lib/cli/*.a /usr/lib/*.a informix@mysite ~$ ./myblademgr ifmx0> How should I change my setup to get the dynamic version of blademgr to work? Any help is more than appreciated, Matthias -- Matthias Wagner Institut fuer Informatik, Universitaet Augsburg wagner@informatik.uni-augsburg.de, www.informatik.uni-augsburg.de phone +49-821-598-2118, fax +49-821-598-2274