Re: ISAM Error Duplicate Value
Posted in 1996
Peter Wiley — — source: Informix-list mailing list archive (1991-1998)
In article <4gh2v5$8c9$1@sydney.DIALix.oz.au> nswdot@sydney.DIALix.oz.au (NSW Department of Transport) writes: >When adding a referential constraint to certain tables I get >the following error > >ISAM Error Duplicate value for record with unique key > >The error appears when I am doing a DBSCHEMA or EBEXPORT of the database > >If I drop the constraint the error disappears >This occurs on some tables but not all. > >Has anyone seen this. >I am running Online version 5.01 on Solaris 2.3 > You *sure* that there's no duplicate rows in that database? Sounds like the tables you're trying to put the constraints on contain rows with non-unique keys. Peter Wiley