Re: Problem establishing an ODBC connection
Posted in 1999
Hi!
I managed to set up the connection with OpenLink ODBC driver!
However if I try to connect with Informix ODBC Driv. 3.30, the sqlexecd
process disappears from ps. The same happens if I choose "Connect to a
database environment" in dbaccess. The returned error message is:
908: Attempt to connect to database server (gambit_ifx) failed.
ISAM error: record is locked
It appears to be very strange to me because the other menu options in
dbaccess work fine (select database, query lang.). And the ILogin tool
doesn't have any problems with the connection either.
I tried to set all DBPATH, DBNAME, INFORMIXDIR, INFORMIXSERVER, ...
oliver
At 16:22 12.10.99 +0000, you wrote:
>Oliver,
>
>Can you connect successfully on the Linux server with the "dbaccess"
>command. You'd have to make sure INFORMIXDIR and INFORMIXSERVER were
>set properly before doing this.
>
>If you're able to get in this way, please ensure you have all the
>appropriate environment variables set in the Openlink oplrqb.ini
>[generic_inf72] section. (Assuming you're using the "Informix 7.2"
>server type). Depending on your version of Openlink, you may have to
>set one or more of the following variables:
>
>DBPATH=<full path to .dbs database>>DELIMIDENT=Y
>INFORMIXDIR=<Informix installation directory> (required)
>INFORMIXSERVER=<Informix server in sqlhosts> (required)>OPL_INF_MULTISESS=Y
>SQLEXEC=sqlexecd
>
>Best Regards,
>
>Stephen Schadt
>Openlink Product Support
>http://www.openlinksw.com
>news://news.openlinksw.com
>
>In article <7tl3if$gp2$1@news.xmission.com>,
> oliver fodor <ofodor@nevado.cui.edu.co> wrote:
>>
>> I can't establish an ODBC connection to my Informix SE database (Linux
>> server) using Informix 3.30 32 Bit ODBC Driver for Win NT (Client).
>When
>> "Testing Connection" in the driver manager, following error message
>appears:
>>
>> SQL error: [Informix][Informix ODBC Driver][Informix]Attempt to>connect to
>> database server (gambit_se) failed.,
>> SQL state 08004 in SQLConnect
>>
>> Please if you can help me with this problem. I have been figting it
>for a
>> long time but can't find any solution.
>>
>> My setup is:
>>
>> Server:
>>
>> - INFORMIXDIR/etc/sqlhosts:
>> gambit_se onsoctcp gambit.cui.edu.co sqlexec>>
>> - sqlexecd started:
>>
>> 1999-10-08 09:09:26.580176 Starting Daemon INFORMIX-SQL Version
>7.24.UC5
>> Command Line = ./sqlexecd gambit_se -l ifx.log
>> INFORMIXDIR = /usr/informixse
>> dbservername = gambit_se
>> nettype = onsoctcp
>> hostname = gambit.cui.edu.co
>> servicename = sqlexec
>> options =
>>
>> - /etc/services:
>>
>> sqlexec 1536/tcp # SUP debugging
>>
>> Client:
>>
>> 1. I set up all the necessary in Setnet32 (INFORMIXDIR,
>INFORMIXSERVER,
>> Server Info, Host Info)
>>
>> 2. The winnt\\system32\\drivers\\etc\\services file includes following
>entry:
>> sqlexec 1536/tcp
>>
>> 3. i created an System DSN with all relevant data
>>
>> ... connection doesn`t work :( neither with OpenLink ODBC Driver
>>
>> thanks, oliver
>>
>
>
>Sent via Deja.com http://www.deja.com/
>Before you buy.