Fatal error in shared memory creation
Posted in 1999
Topics: Installation, Setup & Upgrades, Server Administration, Versions, Editions & End-of-Life
I am new user to Informix. I have installed informix IDS 7.3 on a Linux
server.
Installation went through fine. And first time, I run "oninit -i",
everything seems working until I type in "onmode -k" to stop IDS server.
After I stopped it, restarting by "oninit" or "oninit -i" will give the
following error:
oninit: Fatal error in shared memory creation.
I have not gone very far except following Administrator's guide to set a
online_learn database to experience with it first time.
Any suggestion about solving my problem will be welcomed.
Simon Gao
Hi Simon,
A few things come to mind. (Most of these assume you are only running a
single instance)
First, read your log file. It should give some clues.
Second, Did the instance actually come down? You should see this in the
logs.
Also do "ps -aef|grep oninit" to see if anything is running? If so your
instance was not shut down ( assuming single instance). Were/are your
environment variables set properly. It can get confusing being new to
Informix. INFORMIXDIR, INFORMIXSERVER and ONCONFIG must all be set
properly. Were you logged in as Informix? These are just some of the
things that you might want to check.
Third, Assuming the others are all ok. Check to see if Shared Memory got
cleaned up when you did the "onmode -k". To do this run ipcs -m (this will
show you all the shared memory that have been allocated). You will be
looking for things in the Informix group. To clean these up use "ipcrm id#"
where id# is the number you want to remove. BE CAREFUL WITH ipcrm IT CAN
CAUSE YOU MAJOR HEADACHES IF NOT USED PROPERLY....RTFM
Let me be redundant.
BE CAREFUL WITH ipcrm IT CAN CAUSE YOU MAJOR HEADACHES IF NOT USED
PROPERLY....RTFM
ipcrm can be your best friend or your worst nightmare. Think of it like the
caveman who first discovered fire. Pretty cool stuff till you light your
loincloth on fire ;-)
Hope this helps,
James,
------
The opinions expressed here are my own stupid opinions and do not
necessarily reflect the stupid opinions of my employer...
Simon Gao wrote:
> I am new user to Informix. I have installed informix IDS 7.3 on a Linux
> server.
> Installation went through fine. And first time, I run "oninit -i",
> everything seems working until I type in "onmode -k" to stop IDS server.
>
> After I stopped it, restarting by "oninit" or "oninit -i" will give the
> following error:
> oninit: Fatal error in shared memory creation.
>
> I have not gone very far except following Administrator's guide to set a
> online_learn database to experience with it first time.
>
> Any suggestion about solving my problem will be welcomed.
>
> Simon Gao