COM+ transaction and Informix 7.3 issue
Posted in 2005
kliu — — source: Usenet: comp.databases.informix
Hi, There is a very rare issue when I used COM+ transaction to connect Informix 7.3. A couple of times, the COM+ transaction throw an exception (COMException) to say the transaction is failed. But from the data point of view, all the transaction has finished OK, other than there are thousands of locks left in Informix database. The strange part is that there is no session/connection associated with those locks. So there is no way to release those locks. The database instance has to be restarted to release those locks. Is there anyone has the same issue and knows what the root cause? Thanks very much!