I'm having problems with an ESQL/C program:
a malloc() of about 12 MB fails, returning ENOMEM.
To investigate, I wrote a test function that mallocs and frees
blocks of 1 to 20 MB.
Called before $connect, all the mallocs succeed
(but, inexplicably, the $connect fails with a -25588 in that case).
Called after the $connect, the mallocs above 7 MB fail.
Platform:
Informix Online 7.1
Configuration file is mostly copied from onconfig.std.
Sparc 20, Solaris 2.5, 96MB of physical memory.
The same program works fine with Informix SE.
This sounds like a shared-memory-related problem.
Any ideas or help would be greatly appreciated.
David Anderson
anderson@icsi.berkeley.edu