At 13:54 26/08/97 -0700, you wrote:
}Hi all,
}
} While running this query that should return 259 rows, I get an error.
}
}SELECT * FROM MyTable WHERE MyColumn = 'xxx' ORDER BY MyOtherColumn;
}
}Error:
} 567: Cannot write sorted rows.
} 28: No space left on device
}
}Can anyone point me in the right direction? Thanks in advance.
}
}Bill
}billb@connect3.com
}
This is an OS problem - your disk is full. Run df -k from the Solaris
command line - you will probably find that one of your disks is at
or approaching 100% full. This will cause many problems for the OS,
so it will need to be solved (by your Solaris sysadmin, if that is someone
else. If you *are* the sysadmin, look for large logfiles that could be
deleted, get another disk, move parts of the filesystem onto other disks,
etc). As a temporary fix for your query problem, set your TEMPDIR
variable to a path that is on a disk with sufficient space.
HTH,
Richard.