same View fails to run under IDS 10
Posted in 2005
Topics: Installation, Setup & Upgrades, Storage & Space Management
Hi, I've upgraded from 9.3 FC1 to IDS10 FC1 under Soalris 8. Amazingly, the same view that was running under 9.3 with 240MB TEMPDBSPACE, fails to run under IDS10 with 2.5GB TEMPDBSPACE Can anyone please comment....
My only comment is that we need far more information than this in order to comment intelligently. For example, do you have DBSPACETEMP set in the engine's or the user's environment to point to this temp dbspace. Whyt do you think the problem is the tempspace? What do you mean by 'fails' - did the engine crash? What SQL & ISAM errors did the VIEW fail with? Under what conditions - creating it? Executing a query against it? With or without a WHERE clause? What was the query plan (did you run the query under SET EXPLAIN ON)? Art S. Kagel ----- Original Message ----- From: Adel Al-Johar <adel@kpcim.com.kw> At: 6/21 11:23 Hi, I've upgraded from 9.3 FC1 to IDS10 FC1 under Soalris 8. Amazingly, the same view that was running under 9.3 with 240MB TEMPDBSPACE, fails to run under IDS10 with 2.5GB TEMPDBSPACE Can anyone please comment....
Adel Al-johar said:
> Hi, I've upgraded from 9.3 FC1 to IDS10 FC1 under Soalris 8.
> Amazingly, the same view that was running under 9.3 with 240MB
> TEMPDBSPACE, fails to run under IDS10 with 2.5GB TEMPDBSPACE
>
> Can anyone please comment....
UPDATE STATISTICS?
--
Bye now,
Obnoxio
"C'est pas parce qu'on n'a rien à dire qu'il faut fermer sa gueule"
- Coluche
A smile is a gift that is free to the giver and precious to the recipient.
But giving someone the finger is free too, and I find it more personal and
sincere.
Hi to
all, I thought of DBSPACETEMP because the error I got is the
following "Error (-229): Could not open or create a temporary file." And
the TEMPDBSPACE size was totally consumed during the execution of Select
statement (the view contains Where and Union), and because nothing has
changed at all after the upgrade. Moreover /tmp is nearly empty.
I dropped the database then reloaded with dbimport then I ran UPDATE
STATISTICS, but still no luck. What bother me most is that it was
working under 9.3
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On
Behalf Of Adel Al-johar
Sent: Tuesday, June 21, 2005 5:23 PM
To: ids@iiug.org
Subject: same View fails to run under IDS 10 [5217]
Hi, I've upgraded from 9.3 FC1 to IDS10 FC1 under Soalris 8.
Amazingly, the same view that was running under 9.3 with 240MB
TEMPDBSPACE, fails to run under IDS10 with 2.5GB TEMPDBSPACE
Can anyone please comment....
I was hoping to flush him out! Art S. Kagel ----- Original Message ----- From: Kannan Thirugnanam <Kannan.Thirugnanam@JTax.com> At: 6/21 14:19 Great questions? You certainly make the guy run for cover. Take care, Kannan Thirugnanam -----Original Message----- From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On Behalf Of ART KAGEL, .... Sent: Tuesday, June 21, 2005 11:40 AM To: ids@iiug.org Subject: Re: same View fails to run under IDS 10 [5220] My only comment is that we need far more information than this in order to comment intelligently. For example, do you have DBSPACETEMP set in the engine's or the user's environment to point to this temp dbspace. Whyt do you think the problem is the tempspace? What do you mean by 'fails' - did the engine crash? What SQL & ISAM errors did the VIEW fail with? Under what conditions - creating it? Executing a query against it? With or without a WHERE clause? What was the query plan (did you run the query under SET EXPLAIN ON)? Art S. Kagel ----- Original Message ----- From: Adel Al-Johar <adel@kpcim.com.kw> At: 6/21 11:23 Hi, I've upgraded from 9.3 FC1 to IDS10 FC1 under Soalris 8. Amazingly, the same view that was running under 9.3 with 240MB TEMPDBSPACE, fails to run under IDS10 with 2.5GB TEMPDBSPACE Can anyone please comment.... ***** Jackson Hewitt Email Disclaimer ***** The sender believes that this E-mail and any attachments were free of any virus, worm, Trojan horse, and/or malicious code when sent. This message and its attachments could have been infected during transmission. By reading the message and opening any attachments, the recipient accepts full responsibility for taking protective and remedial action about viruses and other defects. The sender's business entity is not liable for any loss or damage arising in any way from this message or its attachments. Privileged/Confidential Information may be contained in this message. If you are not the addressee indicated in this message (or responsible for delivery of the message to such person), you may not copy or deliver this message to anyone. In such case, you should destroy this message and kindly notify the sender by reply email.