Re: Listener Thread Error
Posted in 1999
pkedar@hotmail.com wrote:
>
> Hi Art,
>
> Thanx for your answer.
>
> I guess tcp listener thread is getting too busy to handle more requests as
> finderr of error 27001 shows:
>
> When you encounter this error on the CLIENT side, it indicates that a
> network I/O error occurred when the client tried to connect to a
> database server. Probably the connection attempt timed out because the
> DATABASE SERVER or the network was VERY BUSY, too many clients were
> attempting to connect to the database server simultaneously, or the
> database server was taken off-line during the connection attempt.
>
> I rule out the possibilities 1.Network is too busy(we restart the engine and
> everything is fine) 2. Too many clients( we have setup 300 connections and we
> have only 100 connections at a time)
I figured you had checked the obvious, dangerous I know but borne out
here.
> I am suspecting maybe listener thread gets too busy and loopy on some dead
> process!!
I don't know about loopy. More likely, as you suggest next, there are
defunct PC connections. PC IP stack software is notorious for not
terminating connections properly (ie calling shutdown etc.) and PC users
are notorious for powering down and shutting down Win* without closing
applications first so.... To defend against this you can try setting the
keepalive parameters in the sqlhosts file on the server for the connection
name that PCs are using so the listener will actively ping each active
connection periodically to determine if the client has died or is just
being quiet. Then the listener threads will drop inactive connections
after a while. But I still do not think that this explains why active
connections are receiving 27001 after a time. Keep plugging away.
Art S. Kagel
> Is it caused by maybe some users are killing their application while database
> is doing some critical SQL processing or power off Client(PC) without closing
> application?
>
> FYI i will check LONGSPINS using onstat -g glo next time listener thread goes
> down.
>
> Does anybody knows about other possibilities of listener thread going LOOPY?
>
> Is their way to restart listener thread?
>
> Thanks in advance.
>
> Praveen Kedar
>
> In article <37A85A29.D5FAC7B4@bloomberg.net>,
> kagel@bloomberg.net wrote:
> > Sounds like a SCO network driver problem to me. Contact SCO.
> >
> > Art S. Kagel
> >
> > pkedar@hotmail.com wrote:
> > >
> > > Hi all,
> > >
> > > We have Informix 7.3.UC2 running on SCO Unix
> > > V5.05 Rel. 3.2 ( 8 processor machine).
> > >
> > > We have setup NETTYPE as tlitcp,3,100,NET and NUMCPUVPS as 3 though we have
> > > around only 100 connections at a time.
> > >
> > > Around 90% connections transfer blob data on those tcp ports and other around
> > > 10% are decision support connections.
> > >
> > > Our listener thread dies frequently(on average in a week) giving following
> > > error:
> > >
> > > online log 09:19:26 listener-thread: err = -25572: oserr = 4: errstr = :
> > > Network driver ca nnot bind a name to the port. System error = 4.
> > >
> > > and on client side -27001 Read error occurred during connection attempt,
> > > connection reset by peer
> > >
> > > After this error no tcp/ip client connections are allowed though all other
> > > shared memory connections and engine is running fine.
> > >
> > > I would really appreciate any help from all those database experts out
> > > there...
> > >
> > > If anyone needs more info about the problem please post a message.
> > >
> > > Thanks in advance.
> > >
> > > Praveen Kedar
> > >
> > > Sent via Deja.com http://www.deja.com/
> > > Share what you know. Learn what you don't.
> >
>
> Sent via Deja.com http://www.deja.com/
> Share what you know. Learn what you don't.