UW7.0.1/Smart Array 3200/IDS 7.30.UC2: Assert Failed cannot fix
Posted in 1999
Topics: Installation, Setup & Upgrades, Storage & Space Management, Error Codes & Troubleshooting, Versions, Editions & End-of-Life
Hi all,
I think I get no luck with this unresolved problem so I would like to post
this problem in hopping there are someone can give me some advises:
We installed Informix Dynamic Server 7.30.UC2 on Unixware 7.0.1 with minimum
patches required by SCO on Compaq Proliant 6500 with Smart Disk Array
controller 3200. The version of Compaq EFS installed in beginning is 7.23
and update to 7.26 and currently with 7.28 but still cannot get out this
problem.
All of the servers (4 Compaqs with the same hardware configuration) were
installed with RAID5 and the create raw devices for Informix's dbspaces with
Volume Manager under UW7.0.1. I tried also with RAID0 but still have the
same problem.
The Informix's support suspect the IDA driver or Compaq Smart Disk Array
hardware problem or missing some patches. I ran the Compaq IDA diagnostics
utility from Compaq EFS under UW7.0.1 and found no error report since
manufactory.
The UW7.0.1 didn't crash but the Informix Dynamic Server crashed often on
two Compaq servers wich have more than 20 users connect to. The Informix
Dynamic Server will not crash if there are under 20 users working.
Here are some errors that I see often when informix crashed:
06:29:09 Assert Failed: Page Check Error in btnext:bad btree node
06:29:09 Informix Dynamic Server Version 7.30.UC2
06:29:09 Who: Session(17681, informix@UWSVR1, 28548, 0)
Thread(330184, xchg_1.1, 0, 3)
File: rsdebug.c Line: 979
06:29:09 Results: Possible inconsistencies in index
'nicoler:"".#u_tab_col_def'
06:29:17 See Also: /tmp/af.9c8bf85
06:29:17 Assert Failed: Dynamic Server must abort
06:29:17 Informix Dynamic Server Version 7.30.UC2
06:29:17 Who: Session(17681, informix@UWSVR1, 28548, 0)
Thread(330184, xchg_1.1, 0, 3)
File: rsshmem.c Line: 1641
06:29:17 Results: Dynamic Server must abort
06:29:24 See Also: /tmp/af.9c8bf85
06:29:24 rsshmem.c, line 1641, thread 330184, proc id 21350, Dynamic Servermus
t abort.
06:29:24 PANIC: Attempting to bring system down
Or :
01:34:20 Assert Failed: Page Check Error in btsearch:bad btree node
01:34:20 Informix Dynamic Server Version 7.30.UC2
01:34:20 Who: Session(3754, denisp@HPUX.domain.com 27796, 0)
Thread(62598, sqlexec, 0, 1)
File: rsdebug.c Line: 979
01:34:20 Results: Possible inconsistencies in index 'dbtest':"".#rci_stt'
01:34:28 See Also: /tmp/af.f4861d6c
Thanks in advance for any help.
H.V
See below. . .
--
In article <6asV3.27191$1v5.500212@newscontent-01.sprint.ca>,
"Huy Vu" <huyv@usa.net> wrote:
> Hi all,
>
> I think I get no luck with this unresolved problem so I would like to
post
> this problem in hopping there are someone can give me some advises:
>
> We installed Informix Dynamic Server 7.30.UC2 on Unixware 7.0.1 with
minimum
> patches required by SCO on Compaq Proliant 6500 with Smart Disk Array
> controller 3200. The version of Compaq EFS installed in beginning is
7.23
> and update to 7.26 and currently with 7.28 but still cannot get out
this
> problem.
>
> All of the servers (4 Compaqs with the same hardware configuration)
were
> installed with RAID5 and the create raw devices for Informix's
dbspaces with
> Volume Manager under UW7.0.1. I tried also with RAID0 but still have
the
Test scenario: create your RAID arrays via Compaq's utilites, install
UW7.0.1 without the Volume Manager, and create your IDS with "cooked"
dbspaces. See what happens. . . . if it stays up, then try creating
the dbspaces on raw devices.
My thoughts: Volume Manager is not (nor do I think it ever has been)
stable on any of the SCO OSes.
Does IDS crash only when users are using it? When IDS is just sitting
idle? Both?
> same problem.
>
> The Informix's support suspect the IDA driver or Compaq Smart Disk
Array
> hardware problem or missing some patches.
Finger pointing to get the monkey off of their back. IDS 7.30 has some
know problems on UW7.1, but I was not aware of any on 7.0.1 . . .
I'm interested in them 'cuz I'm developing a 7x24 call center
application on UW7.0.1 with IDS 7.30UC2, also. Some other threads in
this newsgroup have said that patch PTF7401 on UW7.1 will allow IDS
7.30UC2 to function properly, but I haven't tried that yet.
I do have IDS 7.30UC2 running with about 15 tables created along with
the Enterprise Replication Server. I've left the system up and running
(but without any load on the database) for weeks without any crashes.
Let us all know what you try. . . . thanks :)
> I ran the Compaq IDA diagnostics
> utility from Compaq EFS under UW7.0.1 and found no error report since
> manufactory.
>
> The UW7.0.1 didn't crash but the Informix Dynamic Server crashed often
on
> two Compaq servers wich have more than 20 users connect to. The
Informix
> Dynamic Server will not crash if there are under 20 users working.
>
> Here are some errors that I see often when informix crashed:
I see some index error messages. . . . run 'oncheck -ie' (or something
like that. . . the option which checks the indexes) to see if there are
any problems
> 06:29:09 Assert Failed: Page Check Error in btnext:bad btree node
> 06:29:09 Informix Dynamic Server Version 7.30.UC2
> 06:29:09 Who: Session(17681, informix@UWSVR1, 28548, 0)
> Thread(330184, xchg_1.1, 0, 3)
> File: rsdebug.c Line: 979
> 06:29:09 Results: Possible inconsistencies in index
> 'nicoler:"".#u_tab_col_def'
> 06:29:17 See Also: /tmp/af.9c8bf85
> 06:29:17 Assert Failed: Dynamic Server must abort
> 06:29:17 Informix Dynamic Server Version 7.30.UC2
> 06:29:17 Who: Session(17681, informix@UWSVR1, 28548, 0)
> Thread(330184, xchg_1.1, 0, 3)
> File: rsshmem.c Line: 1641
> 06:29:17 Results: Dynamic Server must abort
> 06:29:24 See Also: /tmp/af.9c8bf85
> 06:29:24 rsshmem.c, line 1641, thread 330184, proc id 21350, DynamicServer
> mus
> t abort.
> 06:29:24 PANIC: Attempting to bring system down>
> Or :
>
> 01:34:20 Assert Failed: Page Check Error in btsearch:bad btree node
> 01:34:20 Informix Dynamic Server Version 7.30.UC2
> 01:34:20 Who: Session(3754, denisp@HPUX.domain.com 27796, 0)
> Thread(62598, sqlexec, 0, 1)
> File: rsdebug.c Line: 979
> 01:34:20 Results: Possible inconsistencies in index
'dbtest':"".#rci_stt'
> 01:34:28 See Also: /tmp/af.f4861d6c>
> Thanks in advance for any help.
>
> H.V
>
>
Sent via Deja.com http://www.deja.com/
Before you buy.