RE: onbar dbspace restore problem
Posted in 1999
I don't know If I quite understand your question.
But the information I think you need is this.
When testing the restore of Dbspace(s); (Warm Restore),
onbar only will restore a dbspace if it is marked down.
To force onbar to restore dbspace(s) not Marked as "down",
do the following :
1. Set environmental variable ARCHIVE_TEST = 1.
2. Type onmode -O {dbspace number}
3. You will see something similar to the following in the Informix Messages
file :
---------------------------------------------------------------------
15:02:46 Assert Failed: WARNING! WARNING! Chunk 2 is being taken OFFLINEfor testing.
15:02:46 Who: Session(8, informix@ultra, 0, 170587664)
Thread(28, onmode_mon, a28f0d8, 1)
15:02:46 Results: DBspace testdbs is disabled.
15:02:46 Action: Restore DBspace testdbs
15:02:46 See Also: /dev/null/af.1c0233
Dropping / deleting records from a table and recovering up to a specific log
file,
just before the drop /deletion :
How I Tested :
1. Verify number of records in a table.
2. Note current log number.
3. Force informix to switch to next log file (onmode -l).
4. Delete a few rows from a table(transaction stored in current log file)
5. Set ARCHIVE_TEST 1, (ARCHIVE_TEST=1; export ARCHIVE_TEST.)
6. Run onbar -r -n {log number to restore up to from step 2} {dbspace}.
This will cause online to mark the dbspace down,
warm restore the dbspace,
salvage the current log file,
then restore up to the current log file.
Output from Informix Message file:
1998-06-05 16:13:03 20008 13961 onbar -r -n 8 testdbs
1998-06-05 16:13:08 20008 13961 Successfully connected to Storage Manager.
1998-06-05 16:15:33 20008 13961 Begin warm level 0 restore testdbs.
1998-06-05 16:15:33 20008 13961 Completed warm level 0 restore testdbs.
1998-06-05 16:15:39 20008 13961 Begin backup logical log 9.
1998-06-05 16:15:39 20008 13961 Successfully connected to Storage Manager.
1998-06-05 16:15:59 20423 20421 onbar -l
1998-06-05 16:16:00 20423 20421 WARNING: A log backup is already running.
Can't start anther.
1998-06-05 16:19:22 20008 13961 Completed backup logical log 9.
1998-06-05 16:19:23 20008 13961 Successfully connected to Storage Manager.
1998-06-05 16:20:07 20008 13961 Begin restore logical log 7.
1998-06-05 16:20:12 20008 13961 Completed restore logical log 7.
1998-06-05 16:22:26 20008 13961 Begin restore logical log 8.
1998-06-05 16:22:26 20008 13961 Completed restore logical log 8.
> -----Original Message-----
> From: suksuk [SMTP:ksshin@comtek.co.kr]
> Sent: Tuesday, January 19, 1999 7:13 PM
> To: informix-list@iiug.org
> Subject: onbar dbspace restore problem
>
> Dear
>
> I have resotre problem using onbar.
>
> -------------------------------------
> <TEST1 >
> Test that dbspace backup , nomal procedure table drop and dbspace restore
> --> fail
>
> 1. # onbar -b insadbs
> 2. "test" table drop in "isadbs" dbspace. (using "dbaccess" command)
> 3. # onbar -r insadbs
> or
> 3. # onbar -r -n 6 insadbs (number 6 is backup logical number)
> or
> 3. # onbar -r -p insadbs
> or
> 3. # onbar -r -t "POINT of BACKUP TIME"
>
> No error messgae displayed.
> But "test" table is not restored.
> --------------------------
>
> <TEST2>
> Test that dbspace backup , nomal procedure dbspace drop and dbspace
> restore
> --> fail
>
>
> 1. # onbar -b insadbs
> 2. "insadbs" dbspace drop all.
> 3. # onbar -r insadbs
>
> No error message displayed.
> "insadbs" dbspace restored.
> But "tset" table is not restored.
>
> ----------------------
> <TEST3>
> Test that dbspace backup , abnormal procedure table drop and dbspace
> restore
> --> successful
>
>
> 1. # onbar -b insadbs
> 2. I removed chncuk of "isadbs" dbspace.
> 3. # onbar -r insadbs
>
> No error message displayed.
> "insadbs" dbspace restored.
> "test" table restored.
>
> -----------------------
> <TEST4>
> Test that full backup , nomal procedure table drop and full restore
> --> successful
>
> 1. # onbar -b -w
> 2. "test" table drop in "isadbs" dbspace. (using "dbaccess" command)
> 3. informix db down
> 3. # onbar -r -w -p
>
> -----------------------
>
> I will summarize the problem.
>
> I can't dbspace restore when data drop by nomal procedure.
>
> In my opinion, this case is written to logical log even drop information.
> When restore, real data is restored, and backup changed logical log, and
> restore again.
> So, data is removed again.
>
> ------------------------
> I want know dbspace restore when data drop by nomal procedure.
> -------------------------------------
>
> Would you check this?