Helmut Leininger wrote:
>
> The transaction will fail with an appropriate SQL/ISAM error code (probably
> -134 ISAM error: no more locks) and be rolled back.
>
> Wu wrote:
>
> > Hi everyone,
> >
> > I am running INFORMIX 7.24UC1 on LINUX.
> >
> > Appreciate if anyone can help me on guessing this (or probably you
> > have experience b4).
> >
> > My informix server has configured for 150,000 for the maximum number
> > of locks, what will happened If I still proceed to run a transaction
> > which required more than 150,000 ? Will the transaction still be
> > successful or failed ?
>
> --
> Helmut Leininger
>
> Bull AG / Vienna
> Unix Support
> Email: Helmut.Leininger@bull.net
>
> This opinion is mine and not necessarily that of my employer.
> No guarantees whatsoever.
You can reduce the number of locks required by locking an entire table
at the start of the transaction with the LOCK TABLE statement. You lose
concurrency, of course.
--
Peter Lancashire
Information Systems Specialist, Bayer plc
Eastern Way, Bury St Edmunds, Suffolk, IP32 7AH, UK
Tel: +44-1635-562258, Fax: +44-1635-562281
---
If all else fails, read the instructions AND the release notes.
All opinions are my own and not those of Bayer plc.
My Internet plumbing does not allow me to mail and post news together.
Sorry.
---
Join Infuse, the UK Informix User Group at http://www.infuse.org.uk/