Shared Memory Problem
Posted in 1999
Topics: Error Codes & Troubleshooting, Platform-Specific Issues
Alex,
After your server crashed it probably left shared memory
segments left behind. You will have to remove them first,
before restarting Informix. Use ipcs/ipcrm commmands.
Alex Bernaards - Bruynzeel Automatisering wrote:
>
> Hi All,
>
> I can't start IDS because of a shared memory problem!
> Working with 7.24.uc6 on hp-ux 10.20
> Hereby a piece of mne online.log:
>
> 17:45:38 mt.c, line 10189, thread 12, proc id 3310, Unexpected virtual> processor termination, pid = 3312, exit = 0x9
> 17:45:38 Assert Failed: Unexpected virtual processor termination, pid =
> 3312, exit = 0x9
> 17:45:38 Who: Session(3, informix@, 0, 0) Thread(12, soctcppoll, 0, 1)
> 17:45:38 Results: Fatal Internal Error requires system shutdown
> 17:45:38 Action: Restart OnLine
> 17:45:38 See Also: /tmp/af.c67b1
> 18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
> 18:08:37 Could not create single shared memory segment with resident and> non-resident partitions. Proceeding to create 2 shared memory segments
> instead.
> 18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
> 18:08:37 mt_shm_init: can't create resident segment>
> Is there sombody who can help get Informix online again?
>
> Thanks,
>
> Alex
Hi All,
I can't start IDS because of a shared memory problem!
Working with 7.24.uc6 on hp-ux 10.20
Hereby a piece of mne online.log:
17:45:38 mt.c, line 10189, thread 12, proc id 3310, Unexpected virtualprocessor termination, pid = 3312, exit = 0x9
17:45:38 Assert Failed: Unexpected virtual processor termination, pid =
3312, exit = 0x9
17:45:38 Who: Session(3, informix@, 0, 0) Thread(12, soctcppoll, 0, 1)
17:45:38 Results: Fatal Internal Error requires system shutdown
17:45:38 Action: Restart OnLine
17:45:38 See Also: /tmp/af.c67b1
18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
18:08:37 Could not create single shared memory segment with resident andnon-resident partitions. Proceeding to create 2 shared memory segments
instead.
18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
18:08:37 mt_shm_init: can't create resident segment
Is there sombody who can help get Informix online again?
Thanks,
Alex
Thanks Rick and Obnoxio,
You put me in the wright direction, ipcs/ipcrm (unix-commands) showed me a
pid.
Checking this pid showwed me some oninit-7.13.UC6 processes.
3 days ago I've installed 7.24.UC6. I've forgotten to change
dbonline-setting in /sbin/init.d
Today was mine first reboot since 3 days.
Stuppid, not? :o(
Alex
Alex Bernaards - Bruynzeel Automatisering <Xpiet@bruynzeel.com> schreef in
berichtnieuws 383d8c2e$0$2547@news2.zeelandnet.nl...
> Hi All,
>
> I can't start IDS because of a shared memory problem!
> Working with 7.24.uc6 on hp-ux 10.20
> Hereby a piece of mne online.log:
>
> 17:45:38 mt.c, line 10189, thread 12, proc id 3310, Unexpected virtual> processor termination, pid = 3312, exit = 0x9
> 17:45:38 Assert Failed: Unexpected virtual processor termination, pid =
> 3312, exit = 0x9
> 17:45:38 Who: Session(3, informix@, 0, 0) Thread(12, soctcppoll, 0, 1)
> 17:45:38 Results: Fatal Internal Error requires system shutdown
> 17:45:38 Action: Restart OnLine
> 17:45:38 See Also: /tmp/af.c67b1
> 18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
> 18:08:37 Could not create single shared memory segment with resident and> non-resident partitions. Proceeding to create 2 shared memory segments
> instead.
> 18:08:37 shmget: [EEXIST][17]: key 52564801: shared memory already exists
> 18:08:37 mt_shm_init: can't create resident segment>
>
> Is there sombody who can help get Informix online again?
>
> Thanks,
>
> Alex
>
>
>