SCO & INFORMIX:Network driver cannot bind a name with the port
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL, Networking & sqlhosts Configuration
Hi people,
hope someone will be able to help me.
OS: SCO Open Server 5.0.5 with rs505a supplement DSBM: INFORMIX Dynamic
Server 7.3 Hardware: HP NetServer LH4 with 2 NICs (HP Netserver 10/100 TX
(main) and Intel EtherExpress PRO/100B), drivers for NICs: first one was
dowloaded from SCO site (as far as I remember), the second one came with the
card. Both installed without any glitch.
Problem:
We are running our main application wich is a series of 4ge files invoked
from main 4ge. Each 4ge connects to the database and we used Informix shared
memory service to connect to the engine ($INFORMIXSERVER,
$INFORMIXDIR/etc/sqlhosts and /etc/services). When we got close to 70+
userthreads (onstat -u) we started having the following error in informix
log:
13:55:30 listener-thread: err = -25572: oserr = 4: errstr = : Network drivercannot bind a name to the port. System error = 4.
We called Informix and they suggested to use tcp service to connect to the
engine. We did and got problem under approaching to 65+ userthreads.
We eneded up with a script which toggles INFORMIXSERVER variable between tcp
and shared during their logon. This allowed us to have up to 218 userthreads
this morning. Which is not sufficient getting worse - we have 149 user
threads at the moment and no one can connect to the engine with the error:
4GL run-time error number -25588. The appl process cannot connect to Dynamic
server <$INFORMIXSERVER>.
and informix log gets one more above line.
We did follow Informix directions in its release docs about kernel
parameters. We checked and it seems there are no services conflicts. tcp/ip
works fine. The box has 11 logical drives and hd major numbers go to 154 not
allowing us to use AIO and SUDS. We found one curious thing: when we were
using just one service the last line of onstat -u looked like:
72 active, 128 total, 112 maximum concurrent
and now, with 2 services, it looks like:
146 active, 256 total, 218 maximum concurrent
mind 128 and 256 what supposed to increment automatically even with one
service.
Do we have problems with number of connections per service?
Any ideas?
Thank you,
Alex.
--
Before the accident, I even could not spell UNIX
--== Sent via Deja.com http://www.deja.com/ ==--
---Share what you know. Learn what you don't.---
THANKS VERY MUCH TO EVERYONE responded. Especially to
"Sistemas & Soluciones SRL" <sissol@amnet.com.pe>
who drawn my attention to SEMMNU kernel parameter. Informix release doc says
set it to 100. Well, with this value of 8192 I was able to get 653 threads
through shared memory wich is more than enough. Users don't complain,
management is happy and life is beautiful! :)
Alex.
"Sistemas & Soluciones SRL" <sissol@amnet.com.pe> wrote:
> Prueve con estos parametros;
> 02 CPU PPro
> 512 MB RAM
>
> -----Original Message-----
> From: Alex Barilo <alex.barilo@phila.gov>
> Newsgroups: comp.databases.informix
> Date: Martes 18 de Mayo de 1999 02:12 PM
> Subject: SCO & INFORMIX:Network driver cannot bind a name with the port
>
> > Hi people,
> >
> > hope someone will be able to help me.
> >
> > OS: SCO Open Server 5.0.5 with rs505a supplement DSBM: INFORMIX Dynamic
> > Server 7.3 Hardware: HP NetServer LH4 with 2 NICs (HP Netserver 10/100 TX
> > (main) and Intel EtherExpress PRO/100B), drivers for NICs: first one was
> > dowloaded from SCO site (as far as I remember), the second one came with the
> > card. Both installed without any glitch.
> >
> > Problem:
> >
> > We are running our main application wich is a series of 4ge files invoked
> > from main 4ge. Each 4ge connects to the database and we used Informix shared
> > memory service to connect to the engine ($INFORMIXSERVER,
> > $INFORMIXDIR/etc/sqlhosts and /etc/services). When we got close to 70+
> > userthreads (onstat -u) we started having the following error in informix
> > log:
> >
> > 13:55:30 listener-thread: err = -25572: oserr = 4: errstr = : Network driver> > cannot bind a name to the port. System error = 4.
> >
> > We called Informix and they suggested to use tcp service to connect to the
> > engine. We did and got problem under approaching to 65+ userthreads.
> >
> > We eneded up with a script which toggles INFORMIXSERVER variable between tcp
> > and shared during their logon. This allowed us to have up to 218 userthreads
> > this morning. Which is not sufficient getting worse - we have 149 user
> > threads at the moment and no one can connect to the engine with the error:
> >
> > 4GL run-time error number -25588. The appl process cannot connect to Dynamic
> > server <$INFORMIXSERVER>.
> >
> > and informix log gets one more above line.
> >
> > We did follow Informix directions in its release docs about kernel
> > parameters. We checked and it seems there are no services conflicts. tcp/ip
> > works fine. The box has 11 logical drives and hd major numbers go to 154 not
> > allowing us to use AIO and SUDS. We found one curious thing: when we were
> > using just one service the last line of onstat -u looked like:
> >
> > 72 active, 128 total, 112 maximum concurrent
> >
> > and now, with 2 services, it looks like:
> >
> > 146 active, 256 total, 218 maximum concurrent
> >
> > mind 128 and 256 what supposed to increment automatically even with one
> > service.
> >
> > Do we have problems with number of connections per service?
> >
> > Any ideas?
> >
> > Thank you,
> > Alex.
> > --
> > Before the accident, I even could not spell UNIX
> >
> > --== Sent via Deja.com http://www.deja.com/ ==--
> > ---Share what you know. Learn what you don't.---
> >
> ----------------------------------------------------------
> /etc/conf/bin/idtune -f SHMMAX 409600000
> /etc/conf/bin/idtune -f SHMMIN 1
> /etc/conf/bin/idtune -f SHMALL 512
> /etc/conf/bin/idtune -f SHMSEG 6
> /etc/conf/bin/idtune -f MAXUMEM 52428700
> /etc/conf/bin/idtune -f SEMMNI 8192
> /etc/conf/bin/idtune -f SEMMNS 8192
> /etc/conf/bin/idtune -f SEMMNU 8192
> /etc/conf/bin/idtune -f SEMMAP 8192
> /etc/conf/bin/idtune -f SEMMSL 25
> /etc/conf/bin/idtune -f NFILE 5000
> /etc/conf/bin/idtune -f NPROC 5000
> /etc/conf/bin/idtune -f NHINODE 1024
> /etc/conf/bin/idtune -f HTCACHEENTS 800
> /etc/conf/bin/idtune -f DTCACHEENTS 800
> /etc/conf/bin/idtune -f NUMSP 288
> /etc/conf/bin/idtune -f NSTREAM 3072
> /etc/conf/bin/idtune -f NSTREVENT 2176
> /etc/conf/bin/idtune -f NUMTIM 272
> /etc/conf/bin/idtune -f NUMTRW 272
> /etc/conf/bin/idtune -f SECLUID 0
> /etc/conf/bin/idtune -f SECSTOPIO
> /etc/conf/bin/idtune -f SECCLEARID 1
> /etc/conf/bin/idtune -f NAIOPROC 16
> /etc/conf/bin/idtune -f NAIOREQ 400
> /etc/conf/bin/idtune -f NAIOBUF 400
> /etc/conf/bin/idtune -f NAIOHBUF 50
> /etc/conf/bin/idtune -f NAIOREQPP 200
> /etc/conf/bin/idtune -f NAIOLOCKTBL 20
> /etc/conf/bin/idtune -f EVQUEUES 71
> /etc/conf/bin/idtune -f EVDEVS 79
> /etc/conf/bin/idtune -f NSPTTYS 63
> /etc/conf/bin/idtune -f NCLIST 270
> /etc/conf/bin/idtune -f NMUXLINK 320
> /etc/conf/bin/idtune -f TTHOG 768
> /etc/conf/bin/idtune -f NSTRPAGES 628
> /etc/conf/bin/idtune -f NOFILES 11000
--
Before the accident, I even could not spell UNIX
--== Sent via Deja.com http://www.deja.com/ ==--
---Share what you know. Learn what you don't.---