delete sysmaster?
Posted in 2014
Topics: Error Codes & Troubleshooting, Platform-Specific Issues
This is on IDS12.10.TC2IE on windows server 2008 R2.
I have a server that will not re-create sysmaster.
The buildsmi.out file says in part :
511: Cannot modify system catalog (systables).
Error in line 1Near character position 23
Database closed.
425: Database is currently opened by another user.
107: ISAM error: record is locked.
Error in line 1Near character position 22
Should I delete sysmaster first?
If so, is this page still correct?
http://www-01.ibm.com/support/docview.wss?uid=swg21444237
Drop sysmaster then run the build script again.
Art
Art S. Kagel, Principal Consultant
ASK Database Management
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on the IIUG, nor any other organization with which I am
associated either explicitly, implicitly, or by inference. Neither do
those opinions reflect those of other individuals affiliated with any
entity with which I am affiliated nor those of the entities themselves.
On Sat, Apr 26, 2014 at 7:54 PM, BillHatVerizon <garage_dba@verizon.net>wrote:
> This is on IDS12.10.TC2IE on windows server 2008 R2.
> I have a server that will not re-create sysmaster.
> The buildsmi.out file says in part :
>
> 511: Cannot modify system catalog (systables).
> Error in line 1> Near character position 23
> Database closed.
>
> 425: Database is currently opened by another user.>
> 107: ISAM error: record is locked.
> Error in line 1> Near character position 22
>
> Should I delete sysmaster first?
>
> If so, is this page still correct?
> http://www-01.ibm.com/support/docview.wss?uid=swg21444237
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--047d7b343d20dab11104f7fbc503
http://www-01.ibm.com/support/docview.wss?uid=swg21444237
Technote (FAQ)
Question
Can the sysmaster database be dropped manually?
Cause
Although it is not recommended to drop the System Monitoring Interface for
Informix, yet under some circumstances a need might exist to drop the
sysmaster database.
Answer
Steps:
dbaccess sysmaster -
delete from systables where tabid > 99 and partnum < '0x100000';
delete from systables where tabname = 'sysdbspartn';
close database;
drop database sysmaster;
Rebuilding sysmaster database -
http://www-01.ibm.com/support/docview.wss?uid=swg21625996