Re: ISAM error: no free disk space
Posted in 1997
Steve Levis wrote: > > Folks, > I am running a ESQL/C query on a 50MB database and getting > the following error messages. > > # 229: Could not open or create a temporary file. > # 131: ISAM error: no free disk space > > There is over 200MB free in /tmp and more that 1GB in the > directory where the root chunk is located. All permissions > in these directories are correct. > > Online Dynamic Server, 7.12, on Solaris. I'm wondering if > anyone can hazard a guess as to the cause of this error. ODS 7.xx creates temp files in one of several places. For sort-work files these go into the directories specified in PSORT_DBTEMP if it is set if not they follow the temp tables. Temp tables are created in one of the dbspaces specified in DBSPACETEMP if it is set in the environment or if not the value of DBSPACETEMP set in the ONCONFIG file, if neither location specifies DBSPACETEMP then temp tables are created in the root dbspace. The root dbspace will not expand no matter how much free space there is in the directory in which it was created (assuming that it was created in filesystem space). Looks like you need to export DBSPACETEMP at least and specify another dbspace other than rootdbs. Best to create temp dbspaces for this purpose. Art S. Kagel