Re: 7 vs 9
Posted in 2005
> > $EXECUTE IMMEDIATE "CREATE INDEX lvo ON lvo( id )"; > > works on 7.x without any problems. But on 9.x the last > > statement fails with sql error -242 (isam -106). Please response > > who knows why the difference exists and which server has bug. > Come to thik about it I don't know why it's not erroring out at the > ROLLBACK. How can you rollback the creation of a temp table when > there is an open WITH HOLD cursor querying that table? It should > get an error on the rollback in either server. If anybody still have interest, send to you support's mail: > Informix R&D have now completed coding a bug fix for this problem. > The fix will be coded into IDS 9.40.UC7. You now have the following > options: > 1) Wait for the fully tested Interim release of IDS 9.40.UC7 to be > released and upgrade to this version to avoid the problem. Or; > 2) Request a patch. So, this is a bug of 9th yet... -- '''''''''' '''''''' '''' '''''''''''' http://pasts.delfi.lv sending to informix-list