IDS 10 Installaion on Suse Linux
Posted in 2008
Topics: Installation, Setup & Upgrades, Server Administration, Platform-Specific Issues
Dear All,
I am trying to create a local database installing IDS 10 on a PC installed
with suse linux.
the RAM = 512 MB
After completing all the onconfig and sql host and env parameters & doing
oninit -iv the server was sucessfully initiallised and showed the status as
online .but then when i hit onstat - for the second time it showed me the error as
shared memory not initialized for INFORMIXSERVER 'ldc_t'.
then i again tried it by making some changes in onconfig parameters like
BUFFSIZE & SHMVIRSIZE and shared mem related parameters.
I am not sure if the kernel parameters has to do any thing with this
I have set
kernel.msgmni=512
kernel.semi=250 128000 32 1024
also saw one behaviour when i was actully able to see the online status for 15
times by hitting onstat -
but then again it showed me the same error .
ipcs |grep informix does not show any result.
Please let me know what calculation do i have to follow for calculating the
onconfig parameters related to usgae of sharedmem & if kernel parameters are
ok with respect to 512 MB Ram
Sorry if any vital info required is not mention by me.
Thanking you in advance
vikas.
Formated one of my drives with NTFS
Hi,
I have'd the same problem,
In my case the problem was have two ip's in two ethernet cards.
The solution was add the 2 ip's in the file /etc/host.equiv
however could be other things with relation to network config.
The message "shared memory not initialized" could be too for bad onconfig
file.
hope it is usefull for you.
regards.
2008/2/19, VIKAS HIVARKAR <vikashivarkar3@gmail.com>:
>
> Dear All,
>
> I am trying to create a local database installing IDS 10 on a PC installed
> with suse linux.
> the RAM = 512 MB
>
> After completing all the onconfig and sql host and env parameters & doing
> oninit -iv the server was sucessfully initiallised and showed the status> as
> online .
> but then when i hit onstat - for the second time it showed me the error as
> shared memory not initialized for INFORMIXSERVER 'ldc_t'.
>
> then i again tried it by making some changes in onconfig parameters like
> BUFFSIZE & SHMVIRSIZE and shared mem related parameters.
>
> I am not sure if the kernel parameters has to do any thing with this
> I have set
> kernel.msgmni=512
> kernel.semi=250 128000 32 1024
>
> also saw one behaviour when i was actully able to see the online status
> for 15
> times by hitting onstat -
> but then again it showed me the same error .
>
> ipcs |grep informix does not show any result.
>
> Please let me know what calculation do i have to follow for calculating
> the
> onconfig parameters related to usgae of sharedmem & if kernel parameters
> are
> ok with respect to 512 MB Ram
>
> Sorry if any vital info required is not mention by me.
>
> Thanking you in advance
>
> vikas.
>
> Formated one of my drives with NTFS
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
> See you at the IIUG Informix 2008 Conference
> The Power Conference for Informix Professionals
> April 27 - 30, 2008 Marriott Overland Park (Kansas City), Kansas
> http://www.iiug.org/conf
> Registration Now Open!!
>