DBEXPORT error
Posted in 2003
Topics: Performance & Tuning, Storage & Space Management, Server Administration, Migration, Import/Export & Data Conversion
Hi there,
I'm looking for help regarding DBEXPORT.
I'm trying to do "routine" maintenance on my "huge" tables, i.e. extent
sizes, fragmentation, etc.
My setup:
Informix 9.21.UC3
DBTEMP=/usr1/dbexport (34GB drive)
DBSPACETEMP=dbs_temp (4GB (2x2GB slices))
user = informix
Solaris 2.7 (1GB RAM, 2x400MHz CPU)
At first use of DBEXPORT, I got the following message after a while:
Disk space may be full. Cannot write to file. Dbexport aborted.
Searching the Internet, I got the following info at:
http://www-3.ibm.com/software/data/informix/pubs/library/notes/relnotes/ids_
win_fixed_and_known_defects_9_30.txt
bug_number 118229
description AN DBEXPORT OF A TABLE CONTAINING 0XFF (ASCII 255) WILL FAIL
WITH "DISK
SPACE FULL. CANNOT WRITE TO FILE. DBEXPORT ABORTED."
product_code DBATOOLS
component_code
The table where DBEXPORT stopped contains a BYTE field.
Then I tried a manual UNLOAD TO FILE SELECT * FROM TABLE of the specified
table using DBACCESS.
The UNLOAD failed and the file size stopped at 2.1GB:
-rw------- 1 informix informix 2147483647 Apr 28 03:06 person_photos.unl
Then I got the following error:
Write failed. 2916 rows unloaded (check ulimit or disk space).
Here is my ulimit output:
$ ulimit -atime(seconds) unlimited
file(blocks) unlimited
data(kbytes) unlimited
stack(kbytes) 8192
coredump(blocks) unlimited
nofiles(descriptors) 64
memory(kbytes) unlimited
And my df -k output:
$ df -kFilesystem kbytes used avail capacity Mounted on
/proc 0 0 0 0% /proc
/dev/dsk/c0t0d0s0 14313947 5869968 8300840 42% /
fd 0 0 0 0% /dev/fd
/dev/dsk/c0t1d0s6 35009161 6536916 28122154 19% /usr1
/dev/dsk/c2t1d0s6 22194372 9 21972420 1% /usr3
swap 3567592 336 3567256 1% /tmp
Then, just for the hell of it I tried doing the UNLOAD TO FILE SELECT * FROM
TABLE
using ROOT.
Still the same error, and again the UNLOAD file size stopped growing at
2.1GB
What am I doing wrong???
I cannot export my tables to do performance tuning.
PLEASE HELP!!!!
Thanx in advance.........
Marius Erasmus
DBA / UNIX Admin
" Never interrupt your enemy when he is making a mistake!! "
Erasmus, Marius wrote
Bits snipped ..
>
> I'm looking for help regarding DBEXPORT.
> I'm trying to do "routine" maintenance on my "huge" tables,
> i.e. extent
> sizes, fragmentation, etc.
>
> The UNLOAD failed and the file size stopped at 2.1GB:
> -rw------- 1 informix informix 2147483647 Apr 28 03:06
> person_photos.unl
>
> Still the same error, and again the UNLOAD file size stopped
> growing at
> 2.1GB
>
> What am I doing wrong???
> I cannot export my tables to do performance tuning.
>
> PLEASE HELP!!!!
>
> Thanx in advance.........
A bit of deja-vu here .
You have hit the 2GB file size limit to do with 32 bit OSs and engines
You can do it by writing to a pipe and zipping it -
this might help from a previous contributor
----------------------------
1. At the unix prompt, create a mknod file,
mknod -m 777 file_name p #### this depends on what OS you are using
2. Now go into dbaccess / isql and start an unload to this file
unload to file_name
select * from table
3. Open another session, and do the following
cat file_name | compress -c > new_file.Z
file_name acts as a buffer area only. You will see that the file size
doesn't increase when you unload. The unload will actually only
start running after you start step 3, so before you start step 3,
it will look like the unload session is hanging.
This should do the trick.
Dirk
-------------------------------
Colin Bull
c.bull@videonetworks.com
Sounds
like a 2G file size limit to me . . .
-----Original Message-----
From: Erasmus, Marius [mailto:MErasmus@ejustice.pwv.gov.za]
Sent: Tuesday, April 29, 2003 5:53 AM
To: ids@iiug.org
Subject: DBEXPORT error [1025]
Hi there,
I'm looking for help regarding DBEXPORT.
I'm trying to do "routine" maintenance on my "huge" tables, i.e. extent
sizes, fragmentation, etc.
My setup:
Informix 9.21.UC3
DBTEMP=/usr1/dbexport (34GB drive)
DBSPACETEMP=dbs_temp (4GB (2x2GB slices))
user = informix
Solaris 2.7 (1GB RAM, 2x400MHz CPU)
At first use of DBEXPORT, I got the following message after a while: Disk
space may be full. Cannot write to file. Dbexport aborted.
Searching the Internet, I got the following info at:
http://www-3.ibm.com/software/data/informix/pubs/library/notes/relnotes/ids_
win_fixed_and_known_defects_9_30.txt
bug_number 118229
description AN DBEXPORT OF A TABLE CONTAINING 0XFF (ASCII 255) WILL FAIL
WITH "DISK
SPACE FULL. CANNOT WRITE TO FILE. DBEXPORT ABORTED."
product_code DBATOOLS
component_code
The table where DBEXPORT stopped contains a BYTE field.
Then I tried a manual UNLOAD TO FILE SELECT * FROM TABLE of the specified
table using DBACCESS.
The UNLOAD failed and the file size stopped at 2.1GB:
-rw------- 1 informix informix 2147483647 Apr 28 03:06 person_photos.unl
Then I got the following error:
Write failed. 2916 rows unloaded (check ulimit or disk space).
Here is my ulimit output:
$ ulimit -atime(seconds) unlimited
file(blocks) unlimited
data(kbytes) unlimited
stack(kbytes) 8192
coredump(blocks) unlimited
nofiles(descriptors) 64
memory(kbytes) unlimited
And my df -k output:
$ df -kFilesystem kbytes used avail capacity Mounted on
/proc 0 0 0 0% /proc
/dev/dsk/c0t0d0s0 14313947 5869968 8300840 42% /
fd 0 0 0 0% /dev/fd
/dev/dsk/c0t1d0s6 35009161 6536916 28122154 19% /usr1
/dev/dsk/c2t1d0s6 22194372 9 21972420 1% /usr3
swap 3567592 336 3567256 1% /tmp
Then, just for the hell of it I tried doing the UNLOAD TO FILE SELECT * FROM
TABLE
using ROOT.
Still the same error, and again the UNLOAD file size stopped growing at
2.1GB
What am I doing wrong???
I cannot export my tables to do performance tuning.
PLEASE HELP!!!!
Thanx in advance.........
Marius Erasmus
DBA / UNIX Admin
" Never interrupt your enemy when he is making a mistake!! "
"CONFIDENTIALITY NOTICE: This message originates from WHSmith USA Travel
Retail. This email message and all attachments may contain legally
privileged and confidential information intended solely for the use of the
addressee. If you are not the intended recipient, you should immediately
stop reading this message and delete it from the system. Any unauthorized
reading, distribution, copying, or other use of this message or its
attachments is strictly prohibited. All personal messages express solely the
sender's views and not those of WHSmith USA Travel Retail. This message may
not be copied or distributed without this disclaimer."
Check out the high performance loader. You can start
that at
www.artentech.com/downloads.htm - the Load FAQ.
cheers
j.
----- Original Message -----
From: "Erasmus, Marius" <MErasmus@ejustice.pwv.gov.za>
To: <ids@iiug.org>
Sent: Tuesday, April 29, 2003 5:52 AM
Subject: DBEXPORT error [1025]
> Hi there,
>
> I'm looking for help regarding DBEXPORT.
> I'm trying to do "routine" maintenance on my "huge" tables, i.e. extent
> sizes, fragmentation, etc.
>
> My setup:
> Informix 9.21.UC3
> DBTEMP=/usr1/dbexport (34GB drive)
> DBSPACETEMP=dbs_temp (4GB (2x2GB slices))
> user = informix
>
> Solaris 2.7 (1GB RAM, 2x400MHz CPU)
>
> At first use of DBEXPORT, I got the following message after a while:
> Disk space may be full. Cannot write to file. Dbexport aborted.
>
> Searching the Internet, I got the following info at:
>
http://www-3.ibm.com/software/data/informix/pubs/library/notes/relnotes/ids_
> win_fixed_and_known_defects_9_30.txt
>
> bug_number 118229
> description AN DBEXPORT OF A TABLE CONTAINING 0XFF (ASCII 255) WILL
FAIL
> WITH "DISK
> SPACE FULL. CANNOT WRITE TO FILE. DBEXPORT ABORTED."
> product_code DBATOOLS
> component_code
>
>
> The table where DBEXPORT stopped contains a BYTE field.
> Then I tried a manual UNLOAD TO FILE SELECT * FROM TABLE of the specified
> table using DBACCESS.
>
> The UNLOAD failed and the file size stopped at 2.1GB:
> -rw------- 1 informix informix 2147483647 Apr 28 03:06 person_photos.unl
>
> Then I got the following error:
> Write failed. 2916 rows unloaded (check ulimit or disk space).
>
> Here is my ulimit output:
> $ ulimit -a> time(seconds) unlimited
> file(blocks) unlimited
> data(kbytes) unlimited
> stack(kbytes) 8192
> coredump(blocks) unlimited
> nofiles(descriptors) 64
> memory(kbytes) unlimited
>
> And my df -k output:
> $ df -k> Filesystem kbytes used avail capacity Mounted on
> /proc 0 0 0 0% /proc
> /dev/dsk/c0t0d0s0 14313947 5869968 8300840 42% /
> fd 0 0 0 0% /dev/fd
> /dev/dsk/c0t1d0s6 35009161 6536916 28122154 19% /usr1
> /dev/dsk/c2t1d0s6 22194372 9 21972420 1% /usr3
> swap 3567592 336 3567256 1% /tmp
>
>
> Then, just for the hell of it I tried doing the UNLOAD TO FILE SELECT *
FROM
> TABLE
> using ROOT.
> Still the same error, and again the UNLOAD file size stopped growing at
> 2.1GB
>
> What am I doing wrong???
> I cannot export my tables to do performance tuning.
>
> PLEASE HELP!!!!
>
> Thanx in advance.........
>
>
> Marius Erasmus
> DBA / UNIX Admin
>
> " Never interrupt your enemy when he is making a mistake!! "
>
>
>
Marius,
I would not advice use DBEXPORT when big tables are involved. Take a look at
High performance loader, that will save you lot of time, and you can
download a table to several files at same time,( if they are in different
file systems better) to overcome the 2 GB limitation problem you are facing
Good luck
Walter
-----Original Message-----
From: Erasmus, Marius [mailto:MErasmus@ejustice.pwv.gov.za]
Sent: Tuesday, April 29, 2003 4:53 AM
To: ids@iiug.org
Subject: DBEXPORT error [1025]
Hi there,
I'm looking for help regarding DBEXPORT.
I'm trying to do "routine" maintenance on my "huge" tables, i.e. extent
sizes, fragmentation, etc.
My setup:
Informix 9.21.UC3
DBTEMP=/usr1/dbexport (34GB drive)
DBSPACETEMP=dbs_temp (4GB (2x2GB slices))
user = informix
Solaris 2.7 (1GB RAM, 2x400MHz CPU)
At first use of DBEXPORT, I got the following message after a while:
Disk space may be full. Cannot write to file. Dbexport aborted.
Searching the Internet, I got the following info at:
http://www-3.ibm.com/software/data/informix/pubs/library/notes/relnotes/ids_
win_fixed_and_known_defects_9_30.txt
bug_number 118229
description AN DBEXPORT OF A TABLE CONTAINING 0XFF (ASCII 255) WILL FAIL
WITH "DISK
SPACE FULL. CANNOT WRITE TO FILE. DBEXPORT ABORTED."
product_code DBATOOLS
component_code
The table where DBEXPORT stopped contains a BYTE field.
Then I tried a manual UNLOAD TO FILE SELECT * FROM TABLE of the specified
table using DBACCESS.
The UNLOAD failed and the file size stopped at 2.1GB:
-rw------- 1 informix informix 2147483647 Apr 28 03:06 person_photos.unl
Then I got the following error:
Write failed. 2916 rows unloaded (check ulimit or disk space).
Here is my ulimit output:
$ ulimit -atime(seconds) unlimited
file(blocks) unlimited
data(kbytes) unlimited
stack(kbytes) 8192
coredump(blocks) unlimited
nofiles(descriptors) 64
memory(kbytes) unlimited
And my df -k output:
$ df -kFilesystem kbytes used avail capacity Mounted on
/proc 0 0 0 0% /proc
/dev/dsk/c0t0d0s0 14313947 5869968 8300840 42% /
fd 0 0 0 0% /dev/fd
/dev/dsk/c0t1d0s6 35009161 6536916 28122154 19% /usr1
/dev/dsk/c2t1d0s6 22194372 9 21972420 1% /usr3
swap 3567592 336 3567256 1% /tmp
Then, just for the hell of it I tried doing the UNLOAD TO FILE SELECT * FROM
TABLE
using ROOT.
Still the same error, and again the UNLOAD file size stopped growing at
2.1GB
What am I doing wrong???
I cannot export my tables to do performance tuning.
PLEASE HELP!!!!
Thanx in advance.........
Marius Erasmus
DBA / UNIX Admin
" Never interrupt your enemy when he is making a mistake!! "