Re: missing SQL exec (std engine)
Posted in 1992
Quoting galem@vnet.ibm.com... } } We have a a process (let's call it XX) which -once started- lives } forever and periodically updates a database by INSERTs and UPDATEs. } When XX is first started, it opens the database (which remains open for } the life of XX) causing an sqlexec child process to be spawned. Our } problem is that occasionally the sqlexec child process disappears with- } out a word, wimper or choke. It is just gone... without a trace! Pre- } ceding its disappearance, at least some records have been INSERTed into } some database tables. However, the amount of time which elapses between } the insertions and the disappearance is very much variable. It may be } minutes ... or hours. Has anyone seen a problem like this??? } } Upon detection of the disappeared sqlexec, we attempted closing the } database and then opening it again. This fails with an error code of } -457, WHICH IS NOT DOCUMENTED in any of our manuals. We have also been } unable to obtain any information from Informix Tech Support regarding } the meaning of this error code. Because we cannot reopen the database, } it would appear that when the original engine exited, it was not done } cleanly. But we haven't a clue about what we can look at to try and } determine what has happened. } From the Informix-5.0 Error Messages manual... -457 SQL engine terminated unexpectedly The database server process with which your application program was working has terminated. If it was Informix-ONLINE, the OnLine administrator may have shut the system down. If it was Informix-SE, it is possible that the database server process was terminated deliberately using an operating system command. If a deliberate shutdown was not done, the next most likely cause is an internal error. The current transaction should be rolled back automagically when the database is next opened. Look for operating system messages that might give more information. If the problem recurs, please note all circumstances and contact the Informix Technical Support Department. NOTE: Be sure to check the ISAM error code returned with this error. If it is -129, the database server has not terminated, but simply reached a limit on the numbers of concurrent user sessions. BTW, have you tried sqlstart() to restart the database? DAS -- David Snyder @ Snide Computer Services - Folcroft, PA Current Release is db4glgen-3.7 UUCP: ..!uunet!das13!dave INTERNET: dave.snyder@snide.com