Re: syscdr not dropped - ER
Posted in 2005
Drop the smartblob and create anything. hariog@yahoo.com wrote: > Hi All, > > IDS 10.00.UC3 > ELAS3.0 > > In one of the test instance, I setup ER which involves setting up > servers on primary & secondary, setup database with no rows in tables > on secondary, defined replicates, started replicates, suspended > primary server so that data can be unloaded from those table which have > been defined for replication. For some reason, I need to rebuild ER > again in this test env., so on primary and then on secondary server, I > deleted the servers. Secondary, syscdr has been dropped successfully > but on primary syscdr still exist. Online log shows: > > CDR GC: operation catalog purge (drop) failed (error -425). > CDR shutdown failed > > I tried again to delete server on primary but got message as "Command > failed - ER not active (62). > > I am pretty sure if I try to define server again I will get "command > failed - fatal server error 100 > > I am hoping sysmaster database has got some pointer back to syscdr. In > normal situation > syscdr get dropped by itself when we delete server but may be server > was in suspend mode and there were some transaction in the queue (for > sure) or some thing else has gone wrong. > > Can some one pl. advise how to drop syscdr cleanly without rebuilding > sysmaster ? > > If rebuilding sysmaster is the only way, will I loose any thing for the > other databases under that instance ? > > TIA > Hari