Re: Q:Online Assert Failed
Posted in 1996
Diana Li <lid> wrote:
>Diana Li <lid> wrote:
>>We are using RAID disk (FORMATION is the vendor) and Online crashes due to it
>>could not get to its critical dbspace. We get this failure in test lab. in
>>a couple of months interval.
>>Question: Can a DBA do something from Informix point of view ?
>> Should someone in system group work with FORMATION for RAID
>> configuration and set up parameters ?
>> Anything else ??
>>Thanks for any response !
>>Error in Online log file:
>>05:39:38 Assert Failed: WARNING! I/O error, Primary Chunk '/dev/infarch1_root'
>>-- Offline
>>05:39:38 Who: Thread(6, main_loop(), 4000a010, 1)
>>05:39:38 Results: Chunk is now unusable
>>05:39:38 Action: Repair and restore from mirror or archive
>>05:39:38 See Also: /tmp/af.8
>>05:39:39 Assert Failed: WARNING! Chunk 1 is being taken OFFLINE.
>>05:39:39 Who: Thread(6, main_loop(), 4000a010, 1)
>>05:39:39 Results: DBspace is disabled.
>>05:39:39 Action: Restore DBspace
>>05:39:39 See Also: /tmp/af.8
>>05:39:39 warning: chunk timestamps are invalid
>>05:39:39 I/O error, Primary Chunk '/dev/infarch1_root' -- Offline (sanity)
>Tolly Brumbelow wrote:
>>>what raid level are you using?
>was raid 5 and then re-configured to raid 1.
If you were originally using RAID-5, did one disk or more than one
disk suffer a hit. I thought if you were on RAID-5 and only one disk
took a hit, you were okay if your root dbspace was on the a RAID-5
device. Anyway, if this is not the case, you did one of two things
that I would have suggested which is using RAID-1 for mirroring or OS
mirroring such as HP Mirror/UX or Informix mirroring to mirror your
root dbspace. Please respond to what RAID level caused the root
dbspace to be marked down and what exactly was the cause of the disk
failure. Thanks in advance.
--
Melvin Mariney, Informix DBA
e-mail: melvin.mariney2@bridge.bellsouth.com