HELP : All logical logs are FULL
Posted in 2006
Topics: Backup & Restore, Server Administration, Logging & Checkpoints
HI All
All my logical logs are full and I have a long running job that have filled
the logs.
I tried to do a backup of the logs with "onbar -b -l", but that gave my the
following error :
2006-10-15 23:50:13 1270002 1343726 (-43381) The logical logs are full.
ON-Bar may encounter errors writing to
the sysutils database.
Then I tried to change the LTAPEDEV in my onconfig to "LTAPEDEV
/dev/null" and tried a backup of the
loggs again but now get the following error :
2006-10-16 04:56:42 1056802 942238 ERROR: Logical Logs will not be backed
up / salvaged because
LTAPEDEV value is /dev/null . Normal backup (onbar -b) cannot be done
without logical logs being backed up,
because restore of such backups requires a logical log restore.
2006-10-16 04:56:42 1056802 942238
/software/informix/10.00.fc4/bin/onbar_d co
mplete, returning 156 (0x9c)
Please HELP
Torben Hansen
If you need this running NOW then run ontape. BUT you will need to come
back and sort it properly, as onbar and ontape are mutually exclusive
Paul Watson
Tel: +44 1414161772
Mob: +44 7818003457
Web: www.oninit.com
GO FURTHER with DB2
GET THERE FASTER with Informix.
Attend IDUG 2007 San Jose, North America
May 6-10, 2006
Visit http://www.iiug.org/conf for more information.
> -----Original Message-----
> From: Torben Hansen [mailto:abrtha@almbrand.dk]
> Posted At: 15 October 2006 22:32
> Posted To: comp.databases.informix
> Conversation: HELP : All logical logs are FULL
> Subject: HELP : All logical logs are FULL
>
>
>
> HI All
>
> All my logical logs are full and I have a long running job
> that have filled the logs.
> I tried to do a backup of the logs with "onbar -b -l", but
> that gave my the following error :
>
> 2006-10-15 23:50:13 1270002 1343726 (-43381) The logical
> logs are full.
> ON-Bar may encounter errors writing to
> the sysutils database.
>
> Then I tried to change the LTAPEDEV in my onconfig to
> "LTAPEDEV /dev/null" and tried a backup of the loggs again
> but now get the following error :
>
> 2006-10-16 04:56:42 1056802 942238 ERROR: Logical Logs will
> not be backed up / salvaged because LTAPEDEV value is
> /dev/null . Normal backup (onbar -b) cannot be done without
> logical logs being backed up, because restore of such backups
> requires a logical log restore.
> 2006-10-16 04:56:42 1056802 942238
> /software/informix/10.00.fc4/bin/onbar_d co mplete, returning
> 156 (0x9c)
>
> Please HELP
>
> Torben Hansen
>
To add - we added "dynamic logical logs" officially in 9.3, and it's
been backported to the 7 line as well.
BUT - with all due respect to Dr. Leffler - if logs didn't get added,
it may not be because the feature is disabled. Dynamic logs is a great
feature, but it doesn't guarantee no long tx's, and if there is not
chunk space available for a contiguous log allocation, a log may not
get added. There is a long-winded pecking order of which dbspace the
newly added log might fall into - it's documented somewhere.
This feature came to light recently on a long assigment of mine - the
client was on IDS 9.21. And of course, ran out of logical logs a couple
of times before remembering that I was battling 9.21.
Mark Scranton
Informix 1995-2006
Paul Watson wrote:
> If you need this running NOW then run ontape. BUT you will need to come
> back and sort it properly, as onbar and ontape are mutually exclusive
>
> Paul Watson
> Tel: +44 1414161772
> Mob: +44 7818003457
> Web: www.oninit.com
>
> GO FURTHER with DB2
> GET THERE FASTER with Informix.
> Attend IDUG 2007 San Jose, North America
> May 6-10, 2006
> Visit http://www.iiug.org/conf for more information.
>
>
>
>
> > -----Original Message-----
> > From: Torben Hansen [mailto:abrtha@almbrand.dk]
> > Posted At: 15 October 2006 22:32
> > Posted To: comp.databases.informix
> > Conversation: HELP : All logical logs are FULL
> > Subject: HELP : All logical logs are FULL
> >
> >
> >
> > HI All
> >
> > All my logical logs are full and I have a long running job
> > that have filled the logs.
> > I tried to do a backup of the logs with "onbar -b -l", but
> > that gave my the following error :
> >
> > 2006-10-15 23:50:13 1270002 1343726 (-43381) The logical
> > logs are full.
> > ON-Bar may encounter errors writing to
> > the sysutils database.
> >
> > Then I tried to change the LTAPEDEV in my onconfig to
> > "LTAPEDEV /dev/null" and tried a backup of the loggs again
> > but now get the following error :
> >
> > 2006-10-16 04:56:42 1056802 942238 ERROR: Logical Logs will
> > not be backed up / salvaged because LTAPEDEV value is
> > /dev/null . Normal backup (onbar -b) cannot be done without
> > logical logs being backed up, because restore of such backups
> > requires a logical log restore.
> > 2006-10-16 04:56:42 1056802 942238
> > /software/informix/10.00.fc4/bin/onbar_d co mplete, returning
> > 156 (0x9c)
> >
> > Please HELP
> >
> > Torben Hansen
> >