Informix sql Error 211 + Isam error 101
Posted in 2008
Topics: Error Codes & Troubleshooting
Hello everyone, i have recently a problem when my aplication start to get a lot of locks, after that any other session try to make a select or any other operation it return error 211 isam 101 Maybe i understand the error 211 but i dont understand why is reporting error 101 im using "IBM Informix Dynamic Server Version 10.00.FC4XB" 7000000d1a277c0 L--PR-- 85270 topsoft - 700000109472380 480 3 3989 1918 7000000d1a28630 L--PR-- 88177 topsoft - 70000010945f438 480 2 97 24 7000000d1a2aa48 Y--P--- 44625 topsoft - 7000001045db800 0 1 102 0 7000000d1a2b180 Y--P--- 42965 gateweb - 7000000d28700a8 0 1 362 0 7000000d1a2bff0 L--PR-- 87870 topsoft - 700000109472380 480 2 1018 200 7000000d1a2dcd0 Y--P--- 86900 jobman - 7000000d4cbc528 0 1 6 48 7000000d1a38a10 Y--P--- 86327 sdjobsop CONBP000 7000000d6d257b8 0 5 169 312 7000000d1a3d978 Y--P--- 88449 topsoft - 7000000e8226d48 0 2 1 0 7000000d1a40c00 L--PR-- 82701 topsoft - 700000109472380 480 2 7351 2600 7000000d1a445c0 L--PR-- 88501 gateweb - 7000000f359c288 120 3 0 0 7000000d1a44cf8 Y--P--- 53173 topsoft - 70000010437d0a8 0 1 8 11 7000000d1a4b940 L--PR-- 88455 gateweb - 7000000f359b1a8 120 3 0 0 7000000d1a4c7b0 Y--P--- 88569 gateweb - 7000000ebbc7cc8 0 1 0 0 7000000d1a4f300 Y--P--- 87948 topsoft - 7000000d5fc5748 0 2 3 0 7000000d1a51718 Y--P--- 88259 topsoft - 7000000e96a9ce8 0 2 1650 312 7000000d1a550d8 L--PR-- 88258 topsoft - 70000010945f438 480 2 49 37 7000000d1a55f48 Y--P--- 79948 sdjobsop COWSP000 7000000d5ef0648 0 2 268 410 7000000d70ec760 L--PR-- 88131 topsoft - 70000010945f438 480 2 648 189 7000000d70ed5d0 --BP--- 84440 topsoft - 0 0 257690 80153 63040 7000000d70edd08 Y--P--- 70464 jobman - 7000000d533ec48 0 1 0 1 7000000d70ee440 Y--P--- 87702 toauxts1 98 7000000d66e96c8 0 1 0 0 when i kill the session 84440 all back to normal, but this already happened a few times. the log dont show any error or abnormality. any help or idea is going to be of help
On 22 Apr, 18:26, ngarima...@gmail.com wrote: > Hello everyone, i have recently a problem when my aplication start to > get a lot of locks, after that any other session try to make a select > or any other operation it return error 211 isam 101 > Maybe i understand the error 211 but i dont understand why is > reporting error 101 > > im using "IBM Informix Dynamic Server Version 10.00.FC4XB" > > 7000000d1a277c0 L--PR-- 85270 topsoft - 700000109472380 > 480 3 3989 1918 > 7000000d1a28630 L--PR-- 88177 topsoft - 70000010945f438 > 480 2 97 24 > 7000000d1a2aa48 Y--P--- 44625 topsoft - 7000001045db800 > 0 1 102 0 > 7000000d1a2b180 Y--P--- 42965 gateweb - 7000000d28700a8 > 0 1 362 0 > 7000000d1a2bff0 L--PR-- 87870 topsoft - 700000109472380 > 480 2 1018 200 > 7000000d1a2dcd0 Y--P--- 86900 jobman - 7000000d4cbc528 > 0 1 6 48 > 7000000d1a38a10 Y--P--- 86327 sdjobsop CONBP000 7000000d6d257b8 > 0 5 169 312 > 7000000d1a3d978 Y--P--- 88449 topsoft - 7000000e8226d48 > 0 2 1 0 > 7000000d1a40c00 L--PR-- 82701 topsoft - 700000109472380 > 480 2 7351 2600 > 7000000d1a445c0 L--PR-- 88501 gateweb - 7000000f359c288 > 120 3 0 0 > 7000000d1a44cf8 Y--P--- 53173 topsoft - 70000010437d0a8 > 0 1 8 11 > 7000000d1a4b940 L--PR-- 88455 gateweb - 7000000f359b1a8 > 120 3 0 0 > 7000000d1a4c7b0 Y--P--- 88569 gateweb - 7000000ebbc7cc8 > 0 1 0 0 > 7000000d1a4f300 Y--P--- 87948 topsoft - 7000000d5fc5748 > 0 2 3 0 > 7000000d1a51718 Y--P--- 88259 topsoft - 7000000e96a9ce8 > 0 2 1650 312 > 7000000d1a550d8 L--PR-- 88258 topsoft - 70000010945f438 > 480 2 49 37 > 7000000d1a55f48 Y--P--- 79948 sdjobsop COWSP000 7000000d5ef0648 > 0 2 268 410 > 7000000d70ec760 L--PR-- 88131 topsoft - 70000010945f438 > 480 2 648 189 > 7000000d70ed5d0 --BP--- 84440 topsoft - 0 > 0 257690 80153 63040 > 7000000d70edd08 Y--P--- 70464 jobman - 7000000d533ec48 > 0 1 0 1 > 7000000d70ee440 Y--P--- 87702 toauxts1 98 7000000d66e96c8 > 0 1 0 0 > > when i kill the session 84440 all back to normal, but this already > happened a few times. > the log dont show any error or abnormality. > > any help or idea is going to be of help What is error 101 in your version of Informix?
ngarimaldi@gmail.com wrote:
> Hello everyone, i have recently a problem when my aplication start to
> get a lot of locks, after that any other session try to make a select
> or any other operation it return error 211 isam 101
> Maybe i understand the error 211 but i dont understand why is
> reporting error 101
>
> im using "IBM Informix Dynamic Server Version 10.00.FC4XB"
>
>
> 7000000d1a277c0 L--PR-- 85270 topsoft - 700000109472380
> 480 3 3989 1918
> 7000000d1a28630 L--PR-- 88177 topsoft - 70000010945f438
> 480 2 97 24
> 7000000d1a2aa48 Y--P--- 44625 topsoft - 7000001045db800
> 0 1 102 0
> 7000000d1a2b180 Y--P--- 42965 gateweb - 7000000d28700a8
> 0 1 362 0
> 7000000d1a2bff0 L--PR-- 87870 topsoft - 700000109472380
> 480 2 1018 200
> 7000000d1a2dcd0 Y--P--- 86900 jobman - 7000000d4cbc528
> 0 1 6 48
> 7000000d1a38a10 Y--P--- 86327 sdjobsop CONBP000 7000000d6d257b8
> 0 5 169 312
> 7000000d1a3d978 Y--P--- 88449 topsoft - 7000000e8226d48
> 0 2 1 0
> 7000000d1a40c00 L--PR-- 82701 topsoft - 700000109472380
> 480 2 7351 2600
> 7000000d1a445c0 L--PR-- 88501 gateweb - 7000000f359c288
> 120 3 0 0
> 7000000d1a44cf8 Y--P--- 53173 topsoft - 70000010437d0a8
> 0 1 8 11
> 7000000d1a4b940 L--PR-- 88455 gateweb - 7000000f359b1a8
> 120 3 0 0
> 7000000d1a4c7b0 Y--P--- 88569 gateweb - 7000000ebbc7cc8
> 0 1 0 0
> 7000000d1a4f300 Y--P--- 87948 topsoft - 7000000d5fc5748
> 0 2 3 0
> 7000000d1a51718 Y--P--- 88259 topsoft - 7000000e96a9ce8
> 0 2 1650 312
> 7000000d1a550d8 L--PR-- 88258 topsoft - 70000010945f438
> 480 2 49 37
> 7000000d1a55f48 Y--P--- 79948 sdjobsop COWSP000 7000000d5ef0648
> 0 2 268 410
> 7000000d70ec760 L--PR-- 88131 topsoft - 70000010945f438
> 480 2 648 189
> 7000000d70ed5d0 --BP--- 84440 topsoft - 0
> 0 257690 80153 63040
> 7000000d70edd08 Y--P--- 70464 jobman - 7000000d533ec48
> 0 1 0 1
> 7000000d70ee440 Y--P--- 87702 toauxts1 98 7000000d66e96c8
> 0 1 0 0
>
> when i kill the session 84440 all back to normal, but this already
> happened a few times.
> the log dont show any error or abnormality.
>
> any help or idea is going to be of help
You should check what locks your session is holding (onstat -k, or a select
from sysmaster).
Is your "84440" session doing something with stored procecures or grants?
There was a situation when this could happen if a procedure needed to have it's
query plan recalculated... usually you'd get locks on sysprocplan. This was
changed in one of the later 10.00.xF* versions (maybe FC6, but I'm not sure...)
Regards
--
Fernando Nunes
Portugal
http://informix-technology.blogspot.com
My email works... but I don't check it frequently...
On 22 abr, 17:54, Fernando Nunes <s...@onlinedomus.net> wrote:
> ngarima...@gmail.com wrote:
> > Hello everyone, i have recently a problem when my aplication start to
> > get a lot of locks, after that any other session try to make a select
> > or any other operation it return error 211 isam 101
> > Maybe i understand the error 211 but i dont understand why is
> > reporting error 101
>
> > im using "IBM Informix Dynamic Server Version 10.00.FC4XB"
>
> > 7000000d1a277c0 L--PR-- 85270 topsoft - 700000109472380
> > 480 3 3989 1918
> > 7000000d1a28630 L--PR-- 88177 topsoft - 70000010945f438
> > 480 2 97 24
> > 7000000d1a2aa48 Y--P--- 44625 topsoft - 7000001045db800
> > 0 1 102 0
> > 7000000d1a2b180 Y--P--- 42965 gateweb - 7000000d28700a8
> > 0 1 362 0
> > 7000000d1a2bff0 L--PR-- 87870 topsoft - 700000109472380
> > 480 2 1018 200
> > 7000000d1a2dcd0 Y--P--- 86900 jobman - 7000000d4cbc528
> > 0 1 6 48
> > 7000000d1a38a10 Y--P--- 86327 sdjobsop CONBP000 7000000d6d257b8
> > 0 5 169 312
> > 7000000d1a3d978 Y--P--- 88449 topsoft - 7000000e8226d48
> > 0 2 1 0
> > 7000000d1a40c00 L--PR-- 82701 topsoft - 700000109472380
> > 480 2 7351 2600
> > 7000000d1a445c0 L--PR-- 88501 gateweb - 7000000f359c288
> > 120 3 0 0
> > 7000000d1a44cf8 Y--P--- 53173 topsoft - 70000010437d0a8
> > 0 1 8 11
> > 7000000d1a4b940 L--PR-- 88455 gateweb - 7000000f359b1a8
> > 120 3 0 0
> > 7000000d1a4c7b0 Y--P--- 88569 gateweb - 7000000ebbc7cc8
> > 0 1 0 0
> > 7000000d1a4f300 Y--P--- 87948 topsoft - 7000000d5fc5748
> > 0 2 3 0
> > 7000000d1a51718 Y--P--- 88259 topsoft - 7000000e96a9ce8
> > 0 2 1650 312
> > 7000000d1a550d8 L--PR-- 88258 topsoft - 70000010945f438
> > 480 2 49 37
> > 7000000d1a55f48 Y--P--- 79948 sdjobsop COWSP000 7000000d5ef0648
> > 0 2 268 410
> > 7000000d70ec760 L--PR-- 88131 topsoft - 70000010945f438
> > 480 2 648 189
> > 7000000d70ed5d0 --BP--- 84440 topsoft - 0
> > 0 257690 80153 63040
> > 7000000d70edd08 Y--P--- 70464 jobman - 7000000d533ec48
> > 0 1 0 1
> > 7000000d70ee440 Y--P--- 87702 toauxts1 98 7000000d66e96c8
> > 0 1 0 0
>
> > when i kill the session 84440 all back to normal, but this already
> > happened a few times.
> > the log dont show any error or abnormality.
>
> > any help or idea is going to be of help
>
> You should check what locks your session is holding (onstat -k, or a select
> from sysmaster).
> Is your "84440" session doing something with stored procecures or grants?
> There was a situation when this could happen if a procedure needed to have it's
> query plan recalculated... usually you'd get locks on sysprocplan. This was
> changed in one of the later 10.00.xF* versions (maybe FC6, but I'm not sure...)
>
> Regards
>
> --
> Fernando Nunes
> Portugal
>
> http://informix-technology.blogspot.com
> My email works... but I don't check it frequently...
Well, i forgot to give you all the information
The error is the next
211: Cannot read system catalog (systables).
System error number -101.
ISAM error: file is not open.
so, is not a problem on sysprocplan is a lock on systables and there
is not any type of exclusive lock on the tables.
Other thing, i cant make select to any table of the DB.
pd: sorry for my pour english im not good writing.
Thx a lot for help
Hi,
I'd suggest to check:
- with oncheck -cc and -cDI that there's not any corruption / inconsistence in the catalog or in the table that you want to access.
- if there is any open file descriptors limit that was reached at the operating system level or at the session level. If you have applications using cursors, it will open new file descriptors as new cursors are opened. If the application doesn't release the resources properly, or consume many resources at managing these cursors, this may lead to reaching the limit in the amount of fd that can be opened per session, at the system level. Here's more info about this:
SQL statement error number -211, SYSTEM error number -101
http://www-1.ibm.com/support/docview.wss?uid=swg21251537
Hope it helps.
Regards,
Veronica.
> From: ngarimaldi@gmail.com
> Subject: Re: Informix sql Error 211 + Isam error 101
> Date: Wed, 23 Apr 2008 06:49:55 -0700
> To: informix-list@iiug.org
>
> On 22 abr, 17:54, Fernando Nunes <s...@onlinedomus.net> wrote:
> > ngarima...@gmail.com wrote:
> > > Hello everyone, i have recently a problem when my aplication start to
> > > get a lot of locks, after that any other session try to make a select
> > > or any other operation it return error 211 isam 101
> > > Maybe i understand the error 211 but i dont understand why is
> > > reporting error 101
> >
> > > im using "IBM Informix Dynamic Server Version 10.00.FC4XB"
> >
> > > 7000000d1a277c0 L--PR-- 85270 topsoft - 700000109472380
> > > 480 3 3989 1918
> > > 7000000d1a28630 L--PR-- 88177 topsoft - 70000010945f438
> > > 480 2 97 24
> > > 7000000d1a2aa48 Y--P--- 44625 topsoft - 7000001045db800
> > > 0 1 102 0
> > > 7000000d1a2b180 Y--P--- 42965 gateweb - 7000000d28700a8
> > > 0 1 362 0
> > > 7000000d1a2bff0 L--PR-- 87870 topsoft - 700000109472380
> > > 480 2 1018 200
> > > 7000000d1a2dcd0 Y--P--- 86900 jobman - 7000000d4cbc528
> > > 0 1 6 48
> > > 7000000d1a38a10 Y--P--- 86327 sdjobsop CONBP000 7000000d6d257b8
> > > 0 5 169 312
> > > 7000000d1a3d978 Y--P--- 88449 topsoft - 7000000e8226d48
> > > 0 2 1 0
> > > 7000000d1a40c00 L--PR-- 82701 topsoft - 700000109472380
> > > 480 2 7351 2600
> > > 7000000d1a445c0 L--PR-- 88501 gateweb - 7000000f359c288
> > > 120 3 0 0
> > > 7000000d1a44cf8 Y--P--- 53173 topsoft - 70000010437d0a8
> > > 0 1 8 11
> > > 7000000d1a4b940 L--PR-- 88455 gateweb - 7000000f359b1a8
> > > 120 3 0 0
> > > 7000000d1a4c7b0 Y--P--- 88569 gateweb - 7000000ebbc7cc8
> > > 0 1 0 0
> > > 7000000d1a4f300 Y--P--- 87948 topsoft - 7000000d5fc5748
> > > 0 2 3 0
> > > 7000000d1a51718 Y--P--- 88259 topsoft - 7000000e96a9ce8
> > > 0 2 1650 312
> > > 7000000d1a550d8 L--PR-- 88258 topsoft - 70000010945f438
> > > 480 2 49 37
> > > 7000000d1a55f48 Y--P--- 79948 sdjobsop COWSP000 7000000d5ef0648
> > > 0 2 268 410
> > > 7000000d70ec760 L--PR-- 88131 topsoft - 70000010945f438
> > > 480 2 648 189
> > > 7000000d70ed5d0 --BP--- 84440 topsoft - 0
> > > 0 257690 80153 63040
> > > 7000000d70edd08 Y--P--- 70464 jobman - 7000000d533ec48
> > > 0 1 0 1
> > > 7000000d70ee440 Y--P--- 87702 toauxts1 98 7000000d66e96c8
> > > 0 1 0 0
> >
> > > when i kill the session 84440 all back to normal, but this already
> > > happened a few times.
> > > the log dont show any error or abnormality.
> >
> > > any help or idea is going to be of help
> >
> > You should check what locks your session is holding (onstat -k, or a select
> > from sysmaster).
> > Is your "84440" session doing something with stored procecures or grants?
> > There was a situation when this could happen if a procedure needed to have it's
> > query plan recalculated... usually you'd get locks on sysprocplan. This was
> > changed in one of the later 10.00.xF* versions (maybe FC6, but I'm not sure...)
> >
> > Regards
> >
> > --
> > Fernando Nunes
> > Portugal
> >
> > http://informix-technology.blogspot.com
> > My email works... but I don't check it frequently...
>
>
> Well, i forgot to give you all the information
>
> The error is the next
>
> 211: Cannot read system catalog (systables).>
> System error number -101.
> ISAM error: file is not open.>
> so, is not a problem on sysprocplan is a lock on systables and there
> is not any type of exclusive lock on the tables.
>
> Other thing, i cant make select to any table of the DB.
>
> pd: sorry for my pour english im not good writing.
>
> Thx a lot for help
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
_________________________________________________________________
Send funny voice messages packed with tidbits from MSN. Everyone wants to be ready.
http://www.noonewantstolookdumb.com?OCID=T001MSN54N1613A
Related threads
- record locked
- who locks a record?
- Regarding Non-Default Page Sizes
- Don't Understand Table's Space Requirement