what's the matter with error -25588
Posted in 2005
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
In my programs wrote in ESQLC, error -25588 encountered. My program forks several child processes,db connection is established in every process and keep alive till end of process. When I fork more processes, certain process will fail to establish connection to informix server(IDS 7.31). Since my program deployed on the same computer with IDS, we use onipcshm as commumication protocol.If I change onipcshm to onsoctcp,no 25588 error occur. What's the reason? Help me,pls. -- Message posted via http://www.dbmonster.com
fei shq via DBMonster.com wrote: > In my programs wrote in ESQLC, error -25588 encountered. > My program forks several child processes,db connection is established in > every process and keep alive till end of process. > When I fork more processes, certain process will fail to establish > connection to informix server(IDS 7.31). > Since my program deployed on the same computer with IDS, we use onipcshm as > commumication protocol.If I change onipcshm to onsoctcp,no 25588 error > occur. > What's the reason? Most likely, the NETTYPE configuration parameter in the ONCONFIG file has too few users listed for the number of connections you're attempting to make. The shared memory connections are fixed at start-up and can't be changed without restarting the server. OTOH, if you run out of network connections, IDS simply starts a new listener thread... -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2005.01 -- http://dbi.perl.org/
If connections is not kept alive, 25588 error is sure to occur while not more child processed forked. That is , in my process , when I need to do something via db, connection is established and release after work finished, some hours later, 25588 error would encountered. I am puzzled. -- Message posted via http://www.dbmonster.com
Related threads
- Re: "Network down" on fresh install
- The appl process cannot connect
- Error 25588 : IDS 7.31UD1 on Solaris8