Problem archecker restore table
Posted in 2009
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Connectivity: ESQL/C, 4GL & Embedded SQL, Security, Permissions & Auditing, Platform-Specific Issues, Versions, Editions & End-of-Life
Good afertenoon
I tried to use archecker to restore a table.
I have two machines in HDR in IDS 11.50.FC3 Solaris 10.
My AC_CONFIG
AC_MSGPATH /tmp/ac_msg.log # archecker message log
AC_STORAGE /tmp # Directory used for temp storage
AC_VERBOSE 1 # 1 verbose messages 0 terse messages
AC_IXBAR /opt/informix/etc/ixbar.2
My definition file:
database venecredit;
create table operador
(
ccodoperador char(8) not null ,
acnomoper1 char(15) not null,
acnomoper2 char(15),
acapeoper1 char(15) not null,
acapeoper2 char(15),
acrango char(2) not null,
creferen_op char(30),
ctelef_op char(14),
cpassword char(8) not null ,
cstatus char(1) not null
) in datadbs;
database test;
create table operador_ext
(
ccodoperador char(8) not null ,
acnomoper1 char(15) not null,
acnomoper2 char(15),
acapeoper1 char(15) not null,
acapeoper2 char(15),
acrango char(2) not null ,
creferen_op char(30),
ctelef_op char(14),
cpassword char(8) not null ,
cstatus char(1) not null
) in datadbs;
insert into test:operador_ext select * from venecredit:operador;restore to current;
I used the next command
archecker -bvs -f /opt/informix/tmp/archfile
The message error:
STATUS: IBM Informix Dynamic Server Version 11.50.FC3
Program Name: archecker
Version: 8.0
Released: 2008-10-28 00:19:58
CSDK: IBM Informix CSDK Version 3.50
ESQL: IBM Informix-ESQL Version 3.50.FN193
Compiled: 10/28/08 00:20 on SunOS 5.9 Generic_122300-31
STATUS: Arguments [-bvs -f /opt/informix/tmp/archfile]
STATUS: AC_STORAGE /tmp
STATUS: AC_MSGPATH /tmp/ac_msg.log
STATUS: AC_VERBOSE on
STATUS: AC_TAPEBLOCK 62 KB
STATUS: AC_IXBAR /opt/informix/etc/ixbar.2
STATUS: AC_SCHEMA /opt/informix/tmp/archfile
TIME: [2009-06-26 14:59:24] All old validation files removed.
STATUS: Dropping old log control tables
ERROR: "EXECUTE IMMEDIATE" failed
ERROR: -19844: Tables of type raw are not allowed in a logged database on an
HDR primary
ERROR: Failed in ACU_SQLSetupCache.
ERROR: "Create table sblob_name" failed
ERROR: -19844: Tables of type raw are not allowed in a logged database on an
HDR primary
ERROR: "Create index name (arc_sbname_index)" failed
ERROR: -206: The specified table (acu_sblob_request) is not in the database.
ERROR: -111: ISAM error: no record found.
ERROR: "Create index name (arc_sbname_index2)" failed
ERROR: -206: The specified table (acu_sblob_request) is not in the database.
ERROR: -111: ISAM error: no record found.
ERROR: "Create table name" failed
ERROR: -19844: Tables of type raw are not allowed in a logged database on an
HDR primary
ERROR: "Create index name (arc_sbname_index)" failed
ERROR: -206: The specified table (acu_sblob_extent) is not in the database.
ERROR: -111: ISAM error: no record found.
ERROR: Failed to start the named blob interface
ERROR: Failed to setup the name interface
ERROR: Setup Handles
CRITICAL ERROR: Unable to initialize extraction
STATUS: archecker completed Physical Restore pid = 21655 exit code: 3
Anybody have idea to fix the problem.
Thank a lot
Regards
Servio Velasco
You are doing everything correctly. There was a defect in version 11.50
which
prevented the creation of any raw tables on a HDR server. Table Level
Restore
from archecker does utilize raw tables when restoring to keep track of
control
information. If you can run this restore on an non-HDR system or upgrade
to
11.50.xC4 which as APAR IC60706 corrected you should be fine.
John F. Miller III
STSM, Support Architect
miller3@us.ibm.com
503-578-5645
IBM Informix Dynamic Server (IDS)
ids-bounces@iiug.org wrote on 06/26/2009 12:54:52 PM:
> [image removed]
>
> Problem archecker restore table [16176]
>
> SERVIO VELASCO
>
> to:
>
> ids
>
> 06/26/2009 12:56 PM
>
> Sent by:
>
> ids-bounces@iiug.org
>
> Please respond to ids
>
> Good afertenoon
>
> I tried to use archecker to restore a table.
>
> I have two machines in HDR in IDS 11.50.FC3 Solaris 10.
>
> My AC_CONFIG
>
> AC_MSGPATH /tmp/ac_msg.log # archecker message log
> AC_STORAGE /tmp # Directory used for temp storage
> AC_VERBOSE 1 # 1 verbose messages 0 terse messages
> AC_IXBAR /opt/informix/etc/ixbar.2
>
> My definition file:
>
> database venecredit;
> create table operador
> (>
> ccodoperador char(8) not null ,
>
> acnomoper1 char(15) not null,
>
> acnomoper2 char(15),
>
> acapeoper1 char(15) not null,
>
> acapeoper2 char(15),
>
> acrango char(2) not null,
>
> creferen_op char(30),
>
> ctelef_op char(14),
>
> cpassword char(8) not null ,
>
> cstatus char(1) not null
> ) in datadbs;
> database test;
> create table operador_ext
> (>
> ccodoperador char(8) not null ,
>
> acnomoper1 char(15) not null,
>
> acnomoper2 char(15),
>
> acapeoper1 char(15) not null,
>
> acapeoper2 char(15),
>
> acrango char(2) not null ,
>
> creferen_op char(30),
>
> ctelef_op char(14),
>
> cpassword char(8) not null ,
>
> cstatus char(1) not null
> ) in datadbs;
> insert into test:operador_ext select * from venecredit:operador;> restore to current;
>
> I used the next command
>
> archecker -bvs -f /opt/informix/tmp/archfile
>
> The message error:
>
> STATUS: IBM Informix Dynamic Server Version 11.50.FC3
> Program Name: archecker
> Version: 8.0
> Released: 2008-10-28 00:19:58
> CSDK: IBM Informix CSDK Version 3.50
> ESQL: IBM Informix-ESQL Version 3.50.FN193
> Compiled: 10/28/08 00:20 on SunOS 5.9 Generic_122300-31
>
> STATUS: Arguments [-bvs -f /opt/informix/tmp/archfile]
> STATUS: AC_STORAGE /tmp
> STATUS: AC_MSGPATH /tmp/ac_msg.log
> STATUS: AC_VERBOSE on
> STATUS: AC_TAPEBLOCK 62 KB
> STATUS: AC_IXBAR /opt/informix/etc/ixbar.2
> STATUS: AC_SCHEMA /opt/informix/tmp/archfile
> TIME: [2009-06-26 14:59:24] All old validation files removed.
> STATUS: Dropping old log control tables
> ERROR: "EXECUTE IMMEDIATE" failed
> ERROR: -19844: Tables of type raw are not allowed in a logged database on
an
> HDR primary
> ERROR: Failed in ACU_SQLSetupCache.
> ERROR: "Create table sblob_name" failed
> ERROR: -19844: Tables of type raw are not allowed in a logged database on
an
> HDR primary
> ERROR: "Create index name (arc_sbname_index)" failed
> ERROR: -206: The specified table (acu_sblob_request) is not in the
database.
> ERROR: -111: ISAM error: no record found.
> ERROR: "Create index name (arc_sbname_index2)" failed
> ERROR: -206: The specified table (acu_sblob_request) is not in the
database.
> ERROR: -111: ISAM error: no record found.
> ERROR: "Create table name" failed
> ERROR: -19844: Tables of type raw are not allowed in a logged database on
an
> HDR primary
> ERROR: "Create index name (arc_sbname_index)" failed
> ERROR: -206: The specified table (acu_sblob_extent) is not in the
database.
> ERROR: -111: ISAM error: no record found.
> ERROR: Failed to start the named blob interface
> ERROR: Failed to setup the name interface
> ERROR: Setup Handles
> CRITICAL ERROR: Unable to initialize extraction
> STATUS: archecker completed Physical Restore pid = 21655 exit code: 3
>
> Anybody have idea to fix the problem.
>
> Thank a lot
>
> Regards
>
> Servio Velasco
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>