can't "set explain on" on ISQL/Linux
Posted in 2001
On Red Hat Linux with ISQL 7.30, SE 7.24 and 4GL, "SET EXPLAIN ON" failed with error 581 "Error loading message file", even though the en_us message directory existed. Jonathan Leffler suspected a product-installation-order clash, since ISQL 7.30 (CSDK 2.30) and SE 7.24 ship different versions of the same message/support files, so one overwrites the other. After trial and error, the poster found the fix: untar and install SE last, after ISQL and 4GL, which resolved the error.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Installation, Setup & Upgrades
When I do a "set explain on" using ISQL . I get this error. I have tried various combinations of DBLANG, so I don't think this is the problem. I have not found any install problems. msg/en_us/0333 exists with message files in it. Anybody have a clue? 581 Error loading message file. This SET EXPLAIN statement could not be completed because the database server was unable to find the file of message templates it uses when it prepares explanatory output. Consult with the person who installed the Informix software. -- mkuhn@rhlab.com
Mike Kuhn wrote: > > When I do a "set explain on" using ISQL . I get this error. > > I have tried various combinations of DBLANG, so I don't think > this is the problem. > > I have not found any install problems. msg/en_us/0333 exists > with message files in it. > > Anybody have a clue? > > 581 Error loading message file. > > This SET EXPLAIN statement could not be completed because the > database server was unable to find the file of message templates > it uses when it prepares explanatory output. Consult with the > person who installed the Informix software. Do you by any chance have ISQL installed on a machine without the database server? It might be the problem -- it shouldn't be, but might be what's up. Basically, if it can't load the correct message file (because it isn't there), then that's the error you get. I'm not sure which message file it is that's required.... -- Yours, Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN "I don't suffer from insanity; I enjoy every minute of it!"
> Do you by any chance have ISQL installed on a machine without the > database server? It might be the problem -- it shouldn't be, but might As in "SE". . . I installed this last. And ISQL will access records in the database that I imported from another machine. Jonathan Leffler wrote: > > Mike Kuhn wrote: > > > > When I do a "set explain on" using ISQL . I get this error. > > > > I have tried various combinations of DBLANG, so I don't think > > this is the problem. > > > > I have not found any install problems. msg/en_us/0333 exists > > with message files in it. > > > > Anybody have a clue? > > > > 581 Error loading message file. > > > > This SET EXPLAIN statement could not be completed because the > > database server was unable to find the file of message templates > > it uses when it prepares explanatory output. Consult with the > > person who installed the Informix software. > > Do you by any chance have ISQL installed on a machine without the > database server? It might be the problem -- it shouldn't be, but might > be what's up. Basically, if it can't load the correct message file > (because it isn't there), then that's the error you get. I'm not sure > which message file it is that's required.... > > -- > Yours, > Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> > Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN > "I don't suffer from insanity; I enjoy every minute of it!" -- mkuhn@rhlab.com
Mike Kuhn wrote: > > Do you by any chance have ISQL installed on a machine without the > > database server? It might be the problem -- it shouldn't be, but might > > As in "SE". . . I installed this last. And ISQL will access records > in the database that I imported from another machine. So, you have ISQL 7.30 and SE 7.24 installed in that order? The old rule of TEN (tools, engines, networks) has gone by the wayside, and it gives me a major brain-ache working out the correct installation sequence (which makes me sorry for everybody else). However, for the products cited, I think the order should be SE then ISQL -- probably. Reasoning? Well, ISQL 7.30 is based on CSDK 2.30 (aka ESQL/C 9.21), whereas SE is still working with ESQL/C 7.24. So, there's a chance that the files needed by ISQL were overwritten by SE -- yes, that's another problem -- and the information that ISQL is looking for simply isn't in the older SE message files. It's semi-speculative -- I've not tried creating a setup to match your environment yet. If absolutely necessary, I'll try to replicate your environment sufficiently to reproduce the problem, but I'll need to know your environment sufficiently accurately to do so, including installation order. > Jonathan Leffler wrote: > > > > Mike Kuhn wrote: > > > > > > When I do a "set explain on" using ISQL . I get this error. > > > > > > I have tried various combinations of DBLANG, so I don't think > > > this is the problem. > > > > > > I have not found any install problems. msg/en_us/0333 exists > > > with message files in it. > > > > > > Anybody have a clue? > > > > > > 581 Error loading message file. > > > > > > This SET EXPLAIN statement could not be completed because the > > > database server was unable to find the file of message templates > > > it uses when it prepares explanatory output. Consult with the > > > person who installed the Informix software. > > > > Do you by any chance have ISQL installed on a machine without the > > database server? It might be the problem -- it shouldn't be, but might > > be what's up. Basically, if it can't load the correct message file > > (because it isn't there), then that's the error you get. I'm not sure > > which message file it is that's required.... -- Yours, Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN "I don't suffer from insanity; I enjoy every minute of it!"
RedHat 6.1 Linux 2.2.12 ISQL 7.30 (Linux 2.2.13 GLIBC 2.1.2) and SE 7.24 I tried two things: 1. deleting installation 2. untar all 3. installing SE, 4gl , ISQL results the same 1. untar'ng ISQL (again by itself) 2. installing ISQL (again) results the same Thanks for the help. While Tech Support might be an advantage here, I can't count on both hands the number of times I have heard from Tech Support. . .since 1988 "Yes its a bug, No we don't know when it will be fixed." Jonathan Leffler wrote: > > Mike Kuhn wrote: > > > Do you by any chance have ISQL installed on a machine without the > > > database server? It might be the problem -- it shouldn't be, but might > > > > As in "SE". . . I installed this last. And ISQL will access records > > in the database that I imported from another machine. > > So, you have ISQL 7.30 and SE 7.24 installed in that order? > > The old rule of TEN (tools, engines, networks) has gone by the wayside, > and it gives me a major brain-ache working out the correct installation > sequence (which makes me sorry for everybody else). > > However, for the products cited, I think the order should be SE then > ISQL -- probably. Reasoning? Well, ISQL 7.30 is based on CSDK 2.30 > (aka ESQL/C 9.21), whereas SE is still working with ESQL/C 7.24. So, > there's a chance that the files needed by ISQL were overwritten by SE -- > yes, that's another problem -- and the information that ISQL is looking > for simply isn't in the older SE message files. It's semi-speculative > -- I've not tried creating a setup to match your environment yet. > > If absolutely necessary, I'll try to replicate your environment > sufficiently to reproduce the problem, but I'll need to know your > environment sufficiently accurately to do so, including installation > order. > > > Jonathan Leffler wrote: > > > > > > Mike Kuhn wrote: > > > > > > > > When I do a "set explain on" using ISQL . I get this error. > > > > > > > > I have tried various combinations of DBLANG, so I don't think > > > > this is the problem. > > > > > > > > I have not found any install problems. msg/en_us/0333 exists > > > > with message files in it. > > > > > > > > Anybody have a clue? > > > > > > > > 581 Error loading message file. > > > > > > > > This SET EXPLAIN statement could not be completed because the > > > > database server was unable to find the file of message templates > > > > it uses when it prepares explanatory output. Consult with the > > > > person who installed the Informix software. > > > > > > Do you by any chance have ISQL installed on a machine without the > > > database server? It might be the problem -- it shouldn't be, but might > > > be what's up. Basically, if it can't load the correct message file > > > (because it isn't there), then that's the error you get. I'm not sure > > > which message file it is that's required.... > > -- > Yours, > Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> > Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN > "I don't suffer from insanity; I enjoy every minute of it!" -- mkuhn@rhlab.com
The solution to this problem is . . . The .tar file for "SE" must be untarred after ISQL and 4GL are installed and SE needs to be installed last. A systematic assault based on Leffler's comments regarding the order of install eventually resolved the problem Thank you Jonathan for taking the time to respond to this. Jonathan Leffler wrote: > > Mike Kuhn wrote: > > > Do you by any chance have ISQL installed on a machine without the > > > database server? It might be the problem -- it shouldn't be, but might > > > > As in "SE". . . I installed this last. And ISQL will access records > > in the database that I imported from another machine. > > So, you have ISQL 7.30 and SE 7.24 installed in that order? > > The old rule of TEN (tools, engines, networks) has gone by the wayside, > and it gives me a major brain-ache working out the correct installation > sequence (which makes me sorry for everybody else). > > However, for the products cited, I think the order should be SE then > ISQL -- probably. Reasoning? Well, ISQL 7.30 is based on CSDK 2.30 > (aka ESQL/C 9.21), whereas SE is still working with ESQL/C 7.24. So, > there's a chance that the files needed by ISQL were overwritten by SE -- > yes, that's another problem -- and the information that ISQL is looking > for simply isn't in the older SE message files. It's semi-speculative > -- I've not tried creating a setup to match your environment yet. > > If absolutely necessary, I'll try to replicate your environment > sufficiently to reproduce the problem, but I'll need to know your > environment sufficiently accurately to do so, including installation > order. > > > Jonathan Leffler wrote: > > > > > > Mike Kuhn wrote: > > > > > > > > When I do a "set explain on" using ISQL . I get this error. > > > > > > > > I have tried various combinations of DBLANG, so I don't think > > > > this is the problem. > > > > > > > > I have not found any install problems. msg/en_us/0333 exists > > > > with message files in it. > > > > > > > > Anybody have a clue? > > > > > > > > 581 Error loading message file. > > > > > > > > This SET EXPLAIN statement could not be completed because the > > > > database server was unable to find the file of message templates > > > > it uses when it prepares explanatory output. Consult with the > > > > person who installed the Informix software. > > > > > > Do you by any chance have ISQL installed on a machine without the > > > database server? It might be the problem -- it shouldn't be, but might > > > be what's up. Basically, if it can't load the correct message file > > > (because it isn't there), then that's the error you get. I'm not sure > > > which message file it is that's required.... > > -- > Yours, > Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> > Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN > "I don't suffer from insanity; I enjoy every minute of it!" -- mkuhn@rhlab.com
On Fri, 16 Feb 2001, Mike Kuhn wrote: >The solution to this problem is . . . > >The .tar file for "SE" must be untarred after ISQL and 4GL are >installed and SE needs to be installed last. Ouch. Hmmm; that means that CSDK tramples on a file used by SE with a version incompatible with SE. Ugh! >A systematic assault based on Leffler's comments regarding >the order of install eventually resolved the problem Ouch; I'm sorry it was so hard to resolve. >Thank you Jonathan for taking the time to respond to this. I guess the rule of TEN sometimes applies even now. I live, I learn. >Jonathan Leffler wrote: >> Mike Kuhn wrote: >> > > Do you by any chance have ISQL installed on a machine without the >> > > database server? It might be the problem -- it shouldn't be, but might >> > >> > As in "SE". . . I installed this last. And ISQL will access records >> > in the database that I imported from another machine. >> >> So, you have ISQL 7.30 and SE 7.24 installed in that order? >> >> The old rule of TEN (tools, engines, networks) has gone by the wayside, >> and it gives me a major brain-ache working out the correct installation >> sequence (which makes me sorry for everybody else). >> >> However, for the products cited, I think the order should be SE then >> ISQL -- probably. Reasoning? Well, ISQL 7.30 is based on CSDK 2.30 >> (aka ESQL/C 9.21), whereas SE is still working with ESQL/C 7.24. So, >> there's a chance that the files needed by ISQL were overwritten by SE -- >> yes, that's another problem -- and the information that ISQL is looking >> for simply isn't in the older SE message files. It's semi-speculative >> -- I've not tried creating a setup to match your environment yet. >> >> If absolutely necessary, I'll try to replicate your environment >> sufficiently to reproduce the problem, but I'll need to know your >> environment sufficiently accurately to do so, including installation >> order. >> >> > Jonathan Leffler wrote: >> > > >> > > Mike Kuhn wrote: >> > > > >> > > > When I do a "set explain on" using ISQL . I get this error. >> > > > >> > > > I have tried various combinations of DBLANG, so I don't think >> > > > this is the problem. >> > > > >> > > > I have not found any install problems. msg/en_us/0333 exists >> > > > with message files in it. >> > > > >> > > > Anybody have a clue? >> > > > >> > > > 581 Error loading message file. >> > > > >> > > > This SET EXPLAIN statement could not be completed because the >> > > > database server was unable to find the file of message templates >> > > > it uses when it prepares explanatory output. Consult with the >> > > > person who installed the Informix software. >> > > >> > > Do you by any chance have ISQL installed on a machine without the >> > > database server? It might be the problem -- it shouldn't be, but might >> > > be what's up. Basically, if it can't load the correct message file >> > > (because it isn't there), then that's the error you get. I'm not sure >> > > which message file it is that's required.... -- Yours, Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN "I don't suffer from insanity; I enjoy every minute of it!"