Re: Help : inf7.2 Client with inf7.1 server
Posted in 1997
>From: "Ilan Shiber" <ilans@magic-sw.com> >Date: 17 Aug 1997 07:30:19 GMT >X-Informix-List-Id: <news.41732> >I have an application compiled with informix 7.2 libraries. >Currently I am working with an informix 7.1 server. The problem is that >when a 7.2 cilent tries to open a connection, it looks for the locale >informiation under $INFORMIXDIR/gsl. This directory exists only for gls >informix 7.2 (which is not installed on my machine), so the SQL command >"connect" fails with -23101 error. So, you've learned the first lesson; to run a program compiled with 7.2x ESQL/C, you need a 7.2x run-time on the system where the program is being run. This is both a technical and, more significantly, a legal requirement. Having said that, it appears that with 7.21 and later versions of 7.x ODS, you automatically get an ESQL/C run-time at no extra cost. However, it is probably only legal to install that on the machine where the 7.2x ODS is running. >I made a small try, and copied the GLS files from another machine, into >the informix 7.1 $INFORMIXDIR, and everything seems to work fine. [...] > >Does informix has a "formal" solution for this problem (for instance, does >it supply the GLS files separatly, so I can install them into any INFORMIX >version), or do I "officially" have to upgrade to INFORMIX7.2 ? You have to install a 7.2x Informix-Connect (ESQL/C RunTime) on the machine where you want to run a 7.2x executable. If you don't have such a licence, your installation is illegal. Yours, Jonathan Leffler (johnl@informix.com) #include <disclaimer.h> PS: Warning I do not reply to messages with anti-spam in the return path.