Re: OnLine 7.2x on Linux
Posted in 1997
> Despite the hacker's delight proposed by Mike, OnLine uses a well known
> algorithm for attaching to shared memory that is based on servernum.
> This error is generally the result of (a) forgetting to reset the
> SERVERNUM parameter in your onconfig file, or (b) having start up
> problems with Informix, leading to allocated shared memory segments not
> being cleaned up when initialization fails.
Pay attention at the back, please! The error is due to mt_exec
failing. The engine decides that is non-recoverable and attempts
to shutdown. It isn't clear whether the following shmget error
is part of the same invocation or not - it is more than 5 minutes
later. It looks like there were two attempts to start the engine,
the first time it failed because he threading didn't work, the
second time it didn't even get that far.
>>09:24:46 invoke_alarm(): mt_exec failed, status -1, errno 0
>>09:24:46 PANIC: Attempting to bring system down
>>09:31:00 shmget: [EEXIST][17]: key 528d4801: shared memory already>>exists 09:31:00 mt_shm_init: can't create resident segment
Mike
P.S. Please don't quote entire message like that. Anyone following
this thread will have access to the original. Also get your sysadmin
to configure the gateway a little better. Embedding PCXs in every
message may be appropriate on your internal CCmail network but it
is inappropriate to say the least when posting to the entire world!
--
.----------------------------------------------------------------------.
| Mike Jagdis | Internet: mailto:mike@roan.co.uk |
| Roan Technology Ltd. | |
| 54A Peach Street, Wokingham | Telephone: +44 118 989 0403 |