Re: Bit-Map has wrong bits set for page
Posted in 1997
There is obviously a problem somewhere, but this may not be as serious as it sounds. There were some bugs in tbcheck that caused these types of errors. Basically what was happening was the tbcheck was not treating some flags correctly on the page. When it then examined the bit map page to see what the if the information matched up with what was there, it got confused. Essentially it decided that a page that was really a data page was really an index page. Kind of a silly error that should not have happened, but it did. This is not to say that you should ignore the problem, but rather that you should examine the problem. I would suggest opening a case with support. Be willing to provide the output of the tbcheck -cd that is producing the error. They will probably need for you to also run some tbcheck -pp or tbcheck -pP to dump the pages in question. If it appears that the problem is that tbcheck is producing erroneous errors, then you should be able to remove the error messages by unloading/reloading the table, or running an "Alter index to cluster". One thing that I can also urge you to consider. This is a rather old problem. You might want to consider moving to one of the more current levels of the 5.x product line. Madison Pruet