HELP: ontape -c error
Posted in 1999
Topics: Backup & Restore, Server Administration, Logging & Checkpoints
Hi all,
Today I tried to backup logical log with command ontape -c but It refused to
work....
After modified TAPEDEV /dev/null and LTAPEDEV /dev/rmt/0m
in $ONCONFIG file
I ran the 'ontape -c' command.
It asked me to put the cassette in /dev/rmt/0m and press enter but the
command fail with error ..../dev/null not allowed....to do backup
log....
Trying to change TAPEDEV to /dev/rmt/0m
and rerun 'ontape -c' but still not fix the error....
Does someone see this problem before ?
Thanks in advance for any help
H.V
Have you stopped and re-started the database server since the change to
LTAPEDEV? Unlike TAPEDEV, this value is not read dynamically, and can only
be changed by bouncing the database engine.
Neil Truby
Londis Stores
Hampton Hill, UK
Huy Vu wrote in message ...
>Hi all,
>
>Today I tried to backup logical log with command ontape -c but It refused
to
>work....
>
>After modified TAPEDEV /dev/null and LTAPEDEV /dev/rmt/0m
>in $ONCONFIG file
>
>I ran the 'ontape -c' command.
>
>It asked me to put the cassette in /dev/rmt/0m and press enter but the
>command fail with error ..../dev/null not allowed....to do backup
>log....
>
>Trying to change TAPEDEV to /dev/rmt/0m
>and rerun 'ontape -c' but still not fix the error....
>
>Does someone see this problem before ?
>
>Thanks in advance for any help
>
>H.V
>
>
>
Huy Vu wrote:
>
> Hi all,
>
> Today I tried to backup logical log with command ontape -c but It refused to
> work....
>
> After modified TAPEDEV /dev/null and LTAPEDEV /dev/rmt/0m
> in $ONCONFIG file
>
> I ran the 'ontape -c' command.
>
> It asked me to put the cassette in /dev/rmt/0m and press enter but the
> command fail with error ..../dev/null not allowed....to do backup
> log....
>
> Trying to change TAPEDEV to /dev/rmt/0m
> and rerun 'ontape -c' but still not fix the error....
>
> Does someone see this problem before ?
Yes. While you CAN change TAPEDEV on the fly using any editor to
modify the onconfig file, the value of LTAPEDEV is read into shared
memory at startup and so must also be changed in memory. Editing the
ONCONFIG file will not change the value of LTAPEDEV until the next time
you bounce the engine. To change LTAPEDEV (and the other LTAPE...
parameters as well) you MUST use onmonitor.
Art S. Kagel
Hi;
how you described it, you didn't do a restart of Online after you changed the
values in the onconfig-file. At that moment, Online has in his memory still
the old information, concerning your backup-device (/dev/null) ->
you get the same message like before.
To get the value in the onconfig-file active, you have to restart Online.
If you want to change the value in a running system: do it with onmonitor: he
will change the
values in the memory also.
Marc
Huy Vu wrote:
> Hi all,
>
> Today I tried to backup logical log with command ontape -c but It refused to
> work....
>
> After modified TAPEDEV /dev/null and LTAPEDEV /dev/rmt/0m
> in $ONCONFIG file
>
> I ran the 'ontape -c' command.
>
> It asked me to put the cassette in /dev/rmt/0m and press enter but the
> command fail with error ..../dev/null not allowed....to do backup
> log....
>
> Trying to change TAPEDEV to /dev/rmt/0m
> and rerun 'ontape -c' but still not fix the error....
>
> Does someone see this problem before ?
>
> Thanks in advance for any help
>
> H.V