Re: Bug 43538
Posted in 1998
In article <6iqi29$8ij$1@news.xmission.com>, KENDRICKS CHERYL <KENDRICKS_CHERYL@heb.com> writes > > > > >Does anyone no the problem this bug could cause... Result of attaching to >the incorrect value for >the SHMBASE? I'm runing INFORMIX-OnLine Version 7.23.UC4. I know the work >around... just >wonder about the effect? > > Online server fails to start or applications fails to attach to shared memory or even server shared memory corruption and data corruption. >Below is the short and long description for bug #43538. >Short description: >SHMBASE VALUE IN ONCONFIG IS ALTERED AFTER ENTERING ONMONITOR, >PARAMETERS,SHARED_MEMORY, THEN ESCAPE WITH NO ALTERATIONS > >Long description: >When a new instance is initialized (with the SHMBASE value set >according to $INFORMIXDIR/release/ONLINE_7.1, which matches onconfig.std), >the >instance comes up fine. >If you check the value of SHMBASE in the onconfig, it is correct. If you >then go into onmonitor,parameters, Shared_Memory, hit escape, say no to the >shutdown message, >and exit from onmonitor, the value of SHMBASE in the ONCONFIG file will be >changed. > >TIA, >Cheryl L. Kendricks >Sr DBA HEB Butt Grocery Co. >San Antonio, Texas >------ You may also send TEXT Based ONLY REPLY TO pgcz@heb.com ------ > > -- David Williams Maintainer of the Informix FAQ Primary site (Beta Version) http://www.smooth1.demon.co.uk Official site http://www.iiug.org/techinfo/faq/faq_top.html I see you standin', Standin' on your own, It's such a lonely place for you, For you to be If you need a shoulder, Or if you need a friend, I'll be here standing, Until the bitter end... So don't chastise me Or think I, I mean you harm... All I ever wanted Was for you To know that I care