Re: ontape -s to disk
Posted in 2004
Right.
BTW: the attentive Informix System Administrator would immediately
notice any problems with the archiving operation, because
he would see the messages about archives aborted or not
successfully completed in the server's message log file ...
[ soap box:
I once got a call from a consultant asking how a damaged IDS
(root dbspace overwritten) can be repaired. My answer was:
"restore", and his reply was that he knows.
The customer was changing archive tapes every evening for
the scripted archiving during the night. They set aside a weekly
archive tape, and they put into long-time storage a monthly tape.
So the customer was best prepared for restore.
The only problem was, that all tapes were empty. Further
investigation revealed, that despite all tape changing activity, the
ontape script never was run, as the IDS message log did not
contain any messages about archive activity. So this customer
had to "recover" from a dbexport that was done more than a
year ago ...
]
Regards,
Martin
--
Martin Fuerderer
IBM Informix Development Munich, Germany
Data Management Solutions
owner-informix-list@iiug.org wrote on 08.12.2004 01:12:03:
> Guys,
>
> I don't want to spoil the party here, but how do you all identify if
> the backup succeeded, or if Informix sent a message "please insert the
> next tape and press return".
>
> this will occur if you archive exceeds the size of your TAPEDEV as
> defined.
>
> this is why IBM informix general don't support archives taken using
> ontape and a script as there is little if any error handling done so
> some months - and archive after archive - later your restore fails with
> a message "Please insert the second tape" and you don't have one.
>
> oh and ....
> "I rather use onbar with ISM, but no $$$"
>
> both onbar and ISM are included with the 7 and 9 servers so I'm not
> sure you need $$$s.
>
sending to informix-list