Re: Error -922
Posted in 1998
In article <6al671$acs$1@news1.teleport.com>, Jeff Raihanan <nbhc@teleport.com> writes >Version: Informix SE 5.0 >Platform: SCO OpenServer 5.0.4 (Unix) > >I can't figure out why I keep getting error -922 (cannot get name of current >working directory). > >I created a new user account (permission is 644 on files and 755 on home >directory). Ownership and group is set properly. Connect privileges have Home directory is 755 hence not writeable by anyone outside the owner's primary group. Bet this is not informix, or the user is not in group informix. >been granted to the new user. When I try to access the database, I get >the -922 error. This isn't the first time this has happened. It seems to >occur whenever I create a new account or new subdirectory within an account. >Somehow, I eventually find a way to work around it (deleting and recreating >the login directory worked once before, but not this time). The funny thing >is that I can cd to the /tmp directory and access the database just fine. I >can cd into another user's home directory and access the database from the >new account just fine too. Check group's, which group both users belong to, the group on the directory and whether any are group informix!! > >Last week, this happened when I created a subdirectory from a user's home >directory. In the subdirectory, I got the -922 if I tried to run isql. In >the parent directory, isql worked just fine. The permissions for the sub >and parent directories are IDENTICAL. Now, here's the weird part: IF I >RENAMED THE SUBDIRECTORY TO AN EXISTING USER, IT WORKED FINE. AS SOON AS I >RENAMED IT BACK, I GOT THE -922. I couldn't believe what I was seeing, so I >did this several times. (In this real-life example, parent directory is >/u/nbhc (nbhc has DBA privileges). When subdirectory was /u/nbhc/tiff, I >got -922. When it's /u/nbhc/tiffany, I don't get -922 (tiffany is one of >our user accounts). When I set it back to /u/nbhc/tiff, the -922 came back. >When I changed the name again to /u/nbhc/wendy (wendy is an account too), it >worked again.) All the directories have the same permissions. > >Can anyone tell me why I get this error and what I can do to fix it? Thanks >very, very much in advance for your help. > >Jeff Raihanan >Information Systems Director >Network Behavioral HealthCare, Inc. >jeff@nbhc.org > > > -- David Williams Maintainer of the Informix FAQ Primary site (Beta Version) http://www.smooth1.demon.co.uk Official site http://www.iiug.org/techinfo/faq/faq_top.html I see you standin', Standin' on your own, It's such a lonely place for you, For you to be If you need a shoulder, Or if you need a friend, I'll be here standing, Until the bitter end... So don't chastise me Or think I, I mean you harm... All I ever wanted Was for you To know that I care