Onbar restore to different box
Posted in 1997
Folks --
We're working this with tech support, but they haven't gotten
us an answer yet, so I thought I'd see if anyone has tried this
before......
We're on Informix 7.22.UC2 on AIX 4.1.5 on an IBM SP (2
processor high node). We recently experienced a catastrophic
failure of a disk which contained logical logs (and wasn't mirrored,
yeah, yeah, I know, it's mirrored now...). So, we had to do a restore
from backups. We had tested restores in a "normal" environment in
the past, but when we tried to recover from the failure, we
got errors saying our backups were corrupted. We recreated our
database from flat files, and are back in business.
We want to figure out what went wrong with the backups.
We use ADSM on a remote server for our storage manager. We're
trying to restore to a different SP node. We've copied over
the ixbar.# file, the onconfig file, the sqlhosts file (with the
name changed appropriately), set up our chunks the same, modified
our ADSM config (we can restore standard files), and try
to do a restore. We get:
1997-08-18 08:52:07 18400 29956 onbar -r -t 1997-08-05 23:59:59 rootdbs
1997-08-18 08:52:21 18400 29956 Successfully connected to Storage
Manager.
1997-08-18 08:52:33 18400 29956 WARNING: ON-Bar was unable to get
backup record of rootdbs from storage manager.
1997-08-18 08:52:34 18400 29956 ERROR: Unable to start the physical
restore: Archive API error: already open.
Has anyone ever restored from onbar to a different node, and if so,
what are we missing?
TIA.
Vic
--
Vic Goldberg - Senior DBA
Cornell Information Technologies
vg19@cornell.edu
(607) 254-7441 (voice) (607) 255-6982 (fax)