Help with ONCONFIG needed
Posted in 2005
Topics: Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
Having a problem with a client connection to an informix database. The server has two databases, db1 and db2. Each database has a separate ONCONFIG file which lists the different db names in them. ONCONFIG_db1 includes db1,but not db2 in the DBSERVERNAME/DBSERVERALIAS ONCONFIG_db2 includes db2,but not db1 in the DBSERVERNAME/DBSERVERALIAS The problem I am having is that when I connect to the server and try to connect to db 2 using "connect to '@db2', I get an error that the INFORMIXSERVER is not in DBSERVERNAME or DBSERVERALIASES. If I try to connect to db1 using connect to '@db1' it works fine. It seems from this that the server is only looking at ONCONFIG_db1, but I have not been able to verify this. I have separate sqlhosts files for each database at the client side and have set the env vars correctly for them. My question is on the ONCONFIG file. Does this file matter on the Client side or does it only matter on the server side? I tried setting the ONCONFIG env var on the client, but it did not change things. Any suggestions would be greatly appreciated.. I am using Informix 9.40 on Solaris. ( both client and server) Thanks.. Tim
I recently hada similar probl;em that turned out to be caused by having the port number for db1 in the cliewnt SQLHOSTS entry for db2. I was surprised at how misleading the error seemed. Sincerely, Christopher Coleman President Kansas City Informix Users Group www.iiug.org/kciug Database Analyst Medication Management Mediware Information Systems, Inc.