Informix installation problem
Posted in 2004
Topics: Installation, Setup & Upgrades, Versions, Editions & End-of-Life
I downloaded IDS 9.4 for win xp from IIUG site but was unable to install it completly. When was installation almost completed i got error: '...cannot start nsrd service' but was able to complete installation but unable to start server at the end,i suppose because of this error.. Can someone please help me with this? thnx
If the nsrd service won't start it's usually because you have another
application on the machine which also uses this service/port. For
example I've seen a clash like this when Microsoft Services for UNIX is
installed.
You only need the nsrd service if you're using ISM/Onbar for backups. If
you use ontape for backups you don't need the nsrd/nsrexecd/portmap
services. If this was the only error you shouldn't have any trouble
starting the IDS service, in fact it mayhave started despite the message
you received. You could check if it is already started by running
"onstat -" from an Informix command window. If it isn't try starting it
with "starts %INFORMIXSERVER%". If it was not successfully started
during installation, then you'll need to initialize it when you start
with "starts %INFORMIXSERVER% -iy".
Regards
Guy
onyx wrote:
> I downloaded IDS 9.4 for win xp from IIUG site but was unable to
> install it completly. When was installation almost completed i got
> error: '...cannot start nsrd service' but was able to complete
> installation but unable to start server at the end,i suppose because
> of this error.. Can someone please help me with this?
>
> thnx