Re: Re-Register BTS.3.10 fails
Posted in 2016
Topics: Installation, Setup & Upgrades, Storage & Space Management, Migration, Import/Export & Data Conversion, Platform-Specific Issues
Run oncheck -cs and oncheck -cS.
Looks like you had a similar problem in 2014 -
http://www.iiug.org/forums/ids/index.cgi/read/34165
What was the solution then?
Otherwise open a case with IBM.
Regards,
David.
> On 19 April 2016 at 18:41 MICHAEL HOFFMAN <offdisc@gmail.com> wrote:
>
>
> Hi All,
> We have an issue with Re-registering the BTS.3.10 blade on Informix 12.10.FC4
> under Solaris 10.
>
> We do regular onunloads of our databases for baselining purposes. That
> function is incompatible with the BTS blade. So before we onunload, we drop
> the BTS index and unregister the blade. However, now that we upgraded to
> 12.10.FC4, we are running into an issue where the re-registration of the
blade
>
> fails.
>
> The error, from 'show last log', is:
>
> blade: bts.3.10
> err expct: unexpected
> SQL stmt: execute procedure bts_CreateStorage("bts_index", 11);
> SQL state: XIX000:-9791 : User Defined Routine (bts_createstorage) execution
> failed.
>
> Interestingly, registering bts.2.00 works fine, and then upgrading to 3.10
> works!
> Here is a screen grab of a full test using blademgr.
> Test 1 -- re-register bts.3.10 ==> FAIL
> Test 2 -- register bts.2.00, unregister & re-register bts.2.00 ==> SUCCESS
> Test 3 -- register bts.3.10 ==> SUCCESS
> Test 4 -- unregister & re-register bts.3.10 ==> FAIL
> Test 5 -- register bts.2.00, unregister & re-register bts.3.10 ==> FAIL
> -----
> foghornfp_tcp>register bts.3.10 fcpang
> Register module bts.3.10 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> blademgr: ERROR: DataBlade bts.3.10 could not be registered in database
> fcpang.
> Use 'show last log' for details of failures in module's scripts.
>
> foghornfp_tcp>register bts.2.00 fcpang
> Register module bts.2.00 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> DataBlade bts.2.00 was successfully registered in database fcpang.
> foghornfp_tcp>unregister bts.2.00 fcpang
> Unregister module bts.2.00 out of database fcpang? [Y/n]y
> DataBlade bts.2.00 was successfully unregistered from Database fcpang.
> foghornfp_tcp>register bts.2.00 fcpang
> Register module bts.2.00 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> DataBlade bts.2.00 was successfully registered in database fcpang.
>
> foghornfp_tcp>register bts.3.10 fcpang
> Register module bts.3.10 into database fcpang? [Y/n]y
> DataBlade module(s) that will be replaced by bts.3.10:
>
> bts.2.00
> Are these changes ok? [Y/n]y
> Registering DataBlade module... (may take a while).
> DataBlade bts.3.10 was successfully registered in database fcpang.
>
> foghornfp_tcp>unregister bts.3.10 fcpang
> Unregister module bts.3.10 out of database fcpang? [Y/n]y
> DataBlade bts.3.10 was successfully unregistered from Database fcpang.
> foghornfp_tcp>register bts.3.10 fcpang
> Register module bts.3.10 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> blademgr: ERROR: DataBlade bts.3.10 could not be registered in database
> fcpang.
> Use 'show last log' for details of failures in module's scripts.
>
> foghornfp_tcp>register bts.2.00 fcpang
> Register module bts.2.00 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> DataBlade bts.2.00 was successfully registered in database fcpang.
> foghornfp_tcp>unregister bts.2.00 fcpang
> Unregister module bts.2.00 out of database fcpang? [Y/n]y
> DataBlade bts.2.00 was successfully unregistered from Database fcpang.
> foghornfp_tcp>register bts.3.10 fcpang
> Register module bts.3.10 into database fcpang? [Y/n]y
> Registering DataBlade module... (may take a while).
> blademgr: ERROR: DataBlade bts.3.10 could not be registered in database
> fcpang.
> Use 'show last log' for details of failures in module's scripts.
> --------------
>
> Database parameters set correctly with bts VP, and sbspaces defined:
> SBSPACETEMP bts_temp
> SBSPACENAME bts_sbspace
> VPCLASS bts,num=3,noyield>
> 10fe86d48 26 0x48001 62 5 2048 N SBA informix bts_sbspace
> 10fe88028 27 0xa001 63 1 2048 N U A informix bts_temp
>
> 745 kaio 9bts* 04/18 10:05:04 0.1173 94 IO Idle
>
> Thanks,
> Michael Hoffman
>
>
>
*******************************************************************************
>
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
Hi David,
Very diffent issue than 2014. Back then, I knew the error was caused by
restoring the database via onload. We no longer due that. The IBM recommended
steps are to drop BTS indexes, unregister blade, onunload database, register
blade, recreate index. We have followed these steps, but now under 12.10.FC4,
the re-register is failing.
BTW, oncheck -csS shows a lot of usage, but has no errors.
(The blade is registered in other DBs, so that can account for the usage).
Same was the case in 2014.
Thanks,
Michael