Illegal sqlhosts file option error due to DNS failure
Posted in 2005
Just a quick note to share a problem encountered today on one of our servers. We have users that connect to an Informix database using an ODBC connection and Microsoft products (Access, Excel, Query) to obtain data. Today, the PCs started giving these errors when connecting: ERROR: -27004: S1000: [Informix][Informix ODBC Driver][Informix]Illegal sqlhosts file option/parameter. The problem turned out to be a failure by the PC to reach the Unix host due to a failed DNS lookup. The ODBC connection was using the host system name instead of its IP address. The DNS server had experienced a problem the previous evening and was never reconfigured properly. This was determined by pings done from the PC: # ping 192.168.77.251 Pinging 192.168.77.251 with 32 bytes of data: Reply from 192.168.77.251: bytes=32 time<10ms TTL=255 Reply from 192.168.77.251: bytes=32 time<10ms TTL=255 Reply from 192.168.77.251: bytes=32 time<10ms TTL=255 Reply from 192.168.77.251: bytes=32 time<10ms TTL=255 Ping statistics for 192.168.77.251: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss), Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms # ping SampleSystem Unable to resolve host entry, SampleSystem So if your ODBC suddenly stops working and gives this error, this may be something for you to test out. Hope it helps someone.