Problems with Locale
Posted in 2001
Topics: Installation, Setup & Upgrades, Platform-Specific Issues, Internationalization & Character Sets
I'm a non-expert at informix, I'm developing a c program for Informix on an AIX 4.3 box, using the CSDK 2.50, and I"m getting the error 23101 when I try to connect. I looked up the follwoing description: [root@p140 bin]# ./finderr -23101 -23101 Unable to load locale categories. An invalid locale name was supplied for the locale initialization. The environment variable to specify the locale category has a wrong value. Check the value of the corresponding environment variable, CLIENT_LOCALE or DB_LOCALE. Also check if INFORMIXDIR points to a valid directory where Informix products are installed. If a client application receives this error when it requests a database server connection, check that the client and database locales are compatible. They are compatible if a valid locale exists on the server computer with the name lg_tr.codeset@mod, where lg_tr (language and territory) and mod (locale modifier) are from the CLIENT_LOCALE and codeset is from the database locale (from the DB_LOCALE, if it is set, or as stored in the database). Can anyone tell me what to set the 2 env varialbes to? I need to know how to look up the locale, and then what values to give hte CLIENT_LOCALE AND DB_LOCALE vars. Any help is appreciated. Mike Baranski Security Managment Consulting
In article <932i3m$c7n$1@news.xmission.com>,
mbaranski@celito.net wrote:
Hi.
I also did a similar experience.
Please try this.
Select sysmaster database.
Run this SQL command "select * from sysdbslocale".
e.g)
select * from sysdbslocale;
dbs_dbsname stores_demo
dbs_collate ja_JP.57351
Hope your helps.
>
> I'm a non-expert at informix, I'm developing a c program for Informix
on
> an AIX 4.3 box, using the CSDK 2.50, and I"m getting the error 23101
> when I try to connect. I looked up the follwoing description:
>
> [root@p140 bin]# ./finderr -23101
> -23101 Unable to load locale categories.
>
> An invalid locale name was supplied for the locale initialization.
> The environment variable to specify the locale category has a wrong
> value. Check the value of the corresponding environment variable,
> CLIENT_LOCALE or DB_LOCALE. Also check if INFORMIXDIR points to a
valid
> directory where Informix products are installed.
>
> If a client application receives this error when it requests a
database
> server connection, check that the client and database locales are
> compatible. They are compatible if a valid locale exists on the
server
> computer with the name lg_tr.codeset@mod, where lg_tr (language and
> territory) and mod (locale modifier) are from the CLIENT_LOCALE and
> codeset is from the database locale (from the DB_LOCALE, if it is
set,
> or as stored in the database).
>
> Can anyone tell me what to set the 2 env varialbes to? I need to
know
> how to look up the locale, and then what values to give hte
> CLIENT_LOCALE AND DB_LOCALE vars. Any help is appreciated.
>
> Mike Baranski
> Security Managment Consulting
>
Regards.
--
Tsutomu Ogiwara from Japan.
Sent via Deja.com
http://www.deja.com/