Re: Online startup error (open files limit)
Posted in 1996
In article <4oif65$t7m@nw101.infi.net>, gtravis@richmond.infi.net says...
>
>I am getting the following error in the server log file when doing an oninit.
>This is the first line of the server log;
>
>17:04:16 Error: Unable to reset open files limit, must run as super-user>
>The server then comes up fine. There are no noticeable problems, except one;
> When connecting to the server through a tcp connection (tli interface), I
get
>the message "User informix is not known on the database server."
>
>Any suggestions? I suspect it is an OS parameter, am waiting for an answer
on
>that.
>
>I am running Online 7.2 on sun (2.3).
>
>thanks.
Yes, I am answering my own question.
Tech Support called back and resolved the issue. Our Online instance was
apparantly installed by user Informix, (instead of root), and this was the
cause of the above listed problems. Several informix binaries need shared
root privilege to properly share resources and open files.
fyi.
--
----------------------------------------------------------------------------
Glenn Travis
Database Administrator
(Ingres/Oracle/Sybase/Informix)
Circuit City Stores, Inc.
Richmond, VA USA
---------------------------------------------------------------------------