RE: dbexport on SCO fails! (horribly)
Posted in 1999
Topics: Connectivity: ODBC / JDBC / .NET, Migration, Import/Export & Data Conversion
If this is an error -100, then this is a known problem with many versions
of dbschema.
There are 2 work-arounds ...
1. Drop all constraints (and I think indexes) from the offending table
and re-try dbschema. When rebuilding put all constraints back manually.
2. Create a manual schema. Unload, drop create, reload table.
To my knowledge there is no fix.
Murray Wood
-----Original Message-----
From: Sven Eric [SMTP:sveneric@xs4all.nl]
Sent: Thursday, June 24, 1999 7:36 PM
To: informix-list@iiug.org
Subject: dbexport on SCO fails! (horribly)
Hi All,
We are trying to copy one of our databases from a SCO system to a Linux
system. Because of the ISAM incompatibility we cannot just copy the
files, we have to do a dbexport on the SCO box and a dbimport on the
Linux box.
The problem is that both dbexport and dbschema fail on the SCO machine
(Informix SE 7.2* <- we tried several versions in the .2 range). Both
programmes complain about indentical values in a table that should only
have unique entries. It concerns a very small table (only four entries),
we checked this table and there were _NO_ duplicate entries. We think
the problem might be that one of our users "manually" modified this
table using an ODBC connection from M$-Access (I hate ODBC). But still
the table and the entries in it appear fine.. (bcheck found no errors)
Is this a known bug in dbexport for SCO? Is there a patched-up version?
Many thanks in advance,
Sven Eric, the Netherlands
dbschema will fail, if the language-environmentvariables differ from
those used in the db (perhaps by creation of the db)
check nls-info and db-nls-info
On
Fri, 25 Jun 1999 12:01:00 +1200, Murray Wood <murray@quanta.co.nz>
wrote:
>
>
>If this is an error -100, then this is a known problem with many versions
>of dbschema.
>There are 2 work-arounds ...
>
> 1. Drop all constraints (and I think indexes) from the offending table
>and re-try dbschema. When rebuilding put all constraints back manually.
>
> 2. Create a manual schema. Unload, drop create, reload table.
>
>To my knowledge there is no fix.
>
>Murray Wood
>
>
>-----Original Message-----
>From: Sven Eric [SMTP:sveneric@xs4all.nl]
>Sent: Thursday, June 24, 1999 7:36 PM
>To: informix-list@iiug.org
>Subject: dbexport on SCO fails! (horribly)
>
>Hi All,
>
>We are trying to copy one of our databases from a SCO system to a Linux
>system. Because of the ISAM incompatibility we cannot just copy the
>files, we have to do a dbexport on the SCO box and a dbimport on the
>Linux box.
>
>The problem is that both dbexport and dbschema fail on the SCO machine
>(Informix SE 7.2* <- we tried several versions in the .2 range). Both
>programmes complain about indentical values in a table that should only
>have unique entries. It concerns a very small table (only four entries),
>we checked this table and there were _NO_ duplicate entries. We think
>the problem might be that one of our users "manually" modified this
>table using an ODBC connection from M$-Access (I hate ODBC). But still
>the table and the entries in it appear fine.. (bcheck found no errors)
>
>Is this a known bug in dbexport for SCO? Is there a patched-up version?
>
>Many thanks in advance,
>
>
>Sven Eric, the Netherlands
>
Related threads
- Fragmentation Fundamental Question
- LVARCHAR data type
- Re: SQL convert number into the date
- Re: Slow dbexport
- doubt about parameters (PDQ)