Table level restore
Posted in 2011
Topics: Backup & Restore, Connectivity: ESQL/C, 4GL & Embedded SQL, Migration, Import/Export & Data Conversion, Platform-Specific Issues, Versions, Editions & End-of-Life
I am trying to do a point in time, table level restore using onbar and IDS
11.50 and Tivoli Storage Manager.
I get the following error from the archecker command. There are no entries in
the dsmerror.log for TSM:
informix@psdb08rpr:~> archecker -bvs -f /home/infrmx/tlr.cmd
IBM Informix Dynamic Server Version 11.50.FC8X4
Program Name: archecker
Version: 8.0
Released: 2011-03-08 09:35:07
CSDK: IBM Informix CSDK Version 3.50
ESQL: IBM Informix-ESQL Version 3.50.FC1
Compiled: 03/08/11 09:35 on Linux 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28
EST 2006
AC_STORAGE /tmp
AC_MSGPATH /tmp/ac_msg.log
AC_VERBOSE on
AC_TAPEBLOCK 62 KB
AC_IXBAR /home/informix/etc/ixbar.74
Dropping old log control tables
CRITICAL ERROR: Unable to initialize extraction
My command file looks like this:
create table 'informix'.chdisposition (cdrserver int,
cdrtime int,
disp_otn CHAR(10) not null,
.
.
.
) in crimhist;
create external table 'informix'.tlr_chdisposition (cdrserver int,
cdrtime int,
disp_otn CHAR(10) not null,
.
.
.
) using ("/IDS/unload/crimhist/tlr_chdisposition.unl", delimiter);
insert into tlr_chdisposition select * from chdisposition;
restore to '2011-07-08 20:20:00' with no log;
Any ideas would be appreciated.
Thanks
Laurie
Laurie Gustin
Database Administrator
Dept of Technology Services
Dept of Public Safety
lgustin@utah.gov
801-965-4410
I found the problem - too late on a sunday trying to do things... I was
missing the database line in the command file (among other things...)
>>> "Laurie Gustin" <lgustin@utah.gov> 7/10/2011 10:46 PM >>>
I am trying to do a point in time, table level restore using onbar and IDS
11.50 and Tivoli Storage Manager.
I get the following error from the archecker command. There are no entries in
the dsmerror.log for TSM:
informix@psdb08rpr:~> archecker -bvs -f /home/infrmx/tlr.cmd
IBM Informix Dynamic Server Version 11.50.FC8X4
Program Name: archecker
Version: 8.0
Released: 2011-03-08 09:35:07
CSDK: IBM Informix CSDK Version 3.50
ESQL: IBM Informix-ESQL Version 3.50.FC1
Compiled: 03/08/11 09:35 on Linux 2.6.9-34.ELsmp #1 SMP Fri Feb 24 16:56:28
EST 2006
AC_STORAGE /tmp
AC_MSGPATH /tmp/ac_msg.log
AC_VERBOSE on
AC_TAPEBLOCK 62 KB
AC_IXBAR /home/informix/etc/ixbar.74
Dropping old log control tables
CRITICAL ERROR: Unable to initialize extraction
My command file looks like this:
create table 'informix'.chdisposition (cdrserver int,
cdrtime int,
disp_otn CHAR(10) not null,
..
..
..
) in crimhist;
create external table 'informix'.tlr_chdisposition (cdrserver int,
cdrtime int,
disp_otn CHAR(10) not null,
..
..
..
) using ("/IDS/unload/crimhist/tlr_chdisposition.unl", delimiter);
insert into tlr_chdisposition select * from chdisposition;
restore to '2011-07-08 20:20:00' with no log;
Any ideas would be appreciated.
Thanks
Laurie
Laurie Gustin
Database Administrator
Dept of Technology Services
Dept of Public Safety
lgustin@utah.gov
801-965-4410
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.